app-admin/pwman3: add python3.7 and python3.8
authorOz N Tiram <oz.tiram@gmail.com>
Thu, 23 Apr 2020 05:40:01 +0000 (08:40 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 23 Apr 2020 06:36:20 +0000 (09:36 +0300)
Closes: https://bugs.gentoo.org/718186
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Oz Tiram <oz.tiram@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15419
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-admin/pwman3/pwman3-0.10.0-r1.ebuild [new file with mode: 0644]

diff --git a/app-admin/pwman3/pwman3-0.10.0-r1.ebuild b/app-admin/pwman3/pwman3-0.10.0-r1.ebuild
new file mode 100644 (file)
index 0000000..fac9659
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1 eutils
+
+DESCRIPTION="A lightweight password-manager with multiple database backends"
+HOMEPAGE="https://pwman3.github.io/pwman3/"
+SRC_URI="https://github.com/pwman3/pwman3/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-python/cryptography-2.3[${PYTHON_USEDEP}]
+       >=dev-python/colorama-0.3.0[${PYTHON_USEDEP}]
+       test? ( dev-python/pexpect[${PYTHON_USEDEP}] )
+       "
+
+distutils_enable_tests setup.py
+
+pkg_postinst() {
+       optfeature "Support for mongodb" dev-python/pymongo
+       optfeature "Support for postgresql" dev-python/psycopg
+       optfeature "Support for mysql" dev-python/pymysql
+}