net-libs/libhubbub: fix test failure
authorVirgil Dupras <vdupras@gentoo.org>
Fri, 25 Jan 2019 20:53:46 +0000 (15:53 -0500)
committerVirgil Dupras <vdupras@gentoo.org>
Fri, 25 Jan 2019 20:55:05 +0000 (15:55 -0500)
Closes: https://bugs.gentoo.org/675836
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

net-libs/libhubbub/libhubbub-0.3.5-r1.ebuild

index d0a20d7641ecfaa26cc80c11a805e7862a315f39..28a147d5b6d9beaba3fb49c8d2c58166550c87af 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit toolchain-funcs
+inherit toolchain-funcs flag-o-matic
 
 DESCRIPTION="HTML5 compliant parsing library, written in C"
 HOMEPAGE="http://www.netsurf-browser.org/projects/hubbub/"
@@ -22,7 +22,7 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig
        test? (
                dev-lang/perl
-               >=dev-libs/json-c-0.10-r1
+               <dev-libs/json-c-0.13
        )"
 
 DOCS=( README docs/{Architecture,Macros,Todo,Treebuilder,Updated} )
@@ -36,6 +36,7 @@ src_prepare() {
 _emake() {
        source /usr/share/netsurf-buildsystem/gentoo-helpers.sh
        netsurf_define_makeconf
+       append-cflags -Wno-error
        emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
 }