dev-python/sphinx-testing: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 11 May 2020 17:45:03 +0000 (19:45 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 11 May 2020 17:45:03 +0000 (19:45 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild [deleted file]

diff --git a/dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild b/dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild
deleted file mode 100644 (file)
index f8f4f5d..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Testing utility classes and functions for Sphinx extensions"
-HOMEPAGE="https://github.com/sphinx-doc/sphinx-testing"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
-       dev-python/sphinx[${PYTHON_USEDEP}]"
-
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-       )"
-
-python_test() {
-       # NB: while tests don't stricly use nose, they rely on some side
-       # effects of using it
-       nosetests -v || die "Tests fail with ${EPYTHON}"
-}