DIST libyui-ncurses-2.47.6.tar.gz 188365 BLAKE2B 47d13ba5109bba0d58b0ac34a6d5032328c63f1aed1fa2ffb10b9bccd3d4ba5cc7ad215e75cc14fd4089a0b4e4d4702e1409f798aae85febaacc2567454ce17e SHA512 c11b4ac6e7d2e5fce52e39abbea5c9c280128071802ee925c00560642cb03e734393b348dc57d3aaff29993b36cdbc371f5766839640162a6e1310810c66e343
+DIST libyui-ncurses-2.48.3.tar.gz 189621 BLAKE2B 360b12f40c6e7dace84e5e10edb32d9b75ec33cb0c796ce31697b90b17df3ac13096d7a3d715d4bf4963c487e705ab4031dbe682f99237331dad951d19c32979 SHA512 18f7cec47aba1fd33443d4154b358c7dd769ed79a5544b11d907f6de461c96fcf1f980ee602781bd3cf3242d692d02721fcf975728a0c00955b34844104419d0
Fixes building with sys-libs/ncurses[tinfo]
---- cmake/Modules/FindCurses6.cmake.orig 2014-09-25 16:32:20.000000000 +0400
-+++ cmake/Modules/FindCurses6.cmake 2014-09-25 16:33:16.000000000 +0400
+--- a/cmake/Modules/FindCurses6.cmake 2014-09-25 16:32:20.000000000 +0400
++++ b/cmake/Modules/FindCurses6.cmake 2014-09-25 16:33:16.000000000 +0400
@@ -11,11 +11,12 @@
FIND_LIBRARY(CURSES6_TINFO_LIBRARY NAMES tinfo PATHS ${path}/ncurses6 ${path} NO_DEFAULT_PATH)
ENDFOREACH()
--- /dev/null
+From 6444e043b58bf7703e4fc9035f380f3817207525 Mon Sep 17 00:00:00 2001
+From: Stefan Hundhammer <shundhammer@suse.de>
+Date: Thu, 4 Jan 2018 17:21:56 +0100
+Subject: [PATCH] Removed function that conflicts with newer NCurses lib
+ (bsc#1074600)
+
+---
+ src/ncursesw.h | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/src/ncursesw.h b/src/ncursesw.h
+index d25923a..c8b95bb 100644
+--- a/src/ncursesw.h
++++ b/src/ncursesw.h
+@@ -1607,14 +1607,6 @@ class NCursesWindow
+ return ::wtouchln( w, s, cnt, ( int )( changed ? 1 : 0 ) );
+ }
+
+- /**
+- * Return TRUE if line is marked as changed, FALSE otherwise
+- */
+- bool is_linetouched( int line ) const
+- {
+- return ( ::is_linetouched( w, line ) ? TRUE : FALSE );
+- }
+-
+ /**
+ * Return TRUE if window is marked as changed, FALSE otherwise
+ */
--- /dev/null
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="UI abstraction library - ncurses plugin"
+HOMEPAGE="https://github.com/libyui/libyui-ncurses"
+SRC_URI="https://github.com/libyui/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="static-libs"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ x11-libs/libyui:${SLOT}
+"
+# Only Boost headers are needed
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.46.4-tinfo.patch"
+ "${FILESDIR}/${P}-ncurses.patch"
+)
+
+src_prepare() {
+ cp "${EPREFIX}/usr/share/libyui/buildtools/CMakeLists.common" CMakeLists.txt || die
+
+ # TODO: set proper docs deps and USE flag for building them
+ sed -i -e '/SET_AUTODOCS/d' CMakeLists.txt || die 'sed on CMakeLists.txt failed'
+ sed -i -e 's/src examples/src/' PROJECTINFO.cmake || die 'sed on PROJECTINFO.cmake failed'
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_EXAMPLES=OFF
+ -DENABLE_WERROR=OFF
+ -DDOC_DIR="${EPREFIX}/usr/share/doc/${PF}"
+ -DRESPECT_FLAGS=ON
+ -DENABLE_STATIC=$(usex static-libs)
+ )
+ cmake-utils_src_configure
+}