dev-ruby/pry: cleanup
authorHans de Graaff <graaff@gentoo.org>
Thu, 9 May 2019 05:34:48 +0000 (07:34 +0200)
committerHans de Graaff <graaff@gentoo.org>
Thu, 9 May 2019 05:53:36 +0000 (07:53 +0200)
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-ruby/pry/Manifest
dev-ruby/pry/pry-0.12.0.ebuild [deleted file]

index 7f1818da7d8269acd17415925a1ba4b7a47a7d2f..bef25e9fc93a0cbb76014d3adee381bab915d5ad 100644 (file)
@@ -1,2 +1 @@
-DIST pry-0.12.0.tar.gz 237643 BLAKE2B 3c1d749c4df638652d0c9e2a11efe1c48225f2aa434e1adb3323fa5cc21fce40f12c7cecdff20589e8329acef30523114292a2834392b53f5d31c40132bc4232 SHA512 bd8ea74c281d64262d499970c0861659679670f052acde37f1d7fa50f2184c816e5681ef2566bf3a6010d150f9c649b39024a79a269e2a7b47057e1d8173d2ce
 DIST pry-0.12.2.tar.gz 237824 BLAKE2B 2a99e6092968150f2c685bc93004bd596adbe5e289bd52ee68f11b52512ac43d0e7079b8129445160652c668c355edae97f1fd0fd2ead940f769831ac9ecf4ff SHA512 b3a2a9a26d7062b994760fc5ca6c8b477813e215624d88ae56d23703429d3d8d21357b5d89583c1af1c7654f892c0c57ffbc6dd6b6f126e0a6b786c7c48df6af
diff --git a/dev-ruby/pry/pry-0.12.0.ebuild b/dev-ruby/pry/pry-0.12.0.ebuild
deleted file mode 100644 (file)
index dca7baa..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_DOC="yard"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
-RUBY_FAKEGEM_GEMSPEC=${PN}.gemspec
-
-inherit ruby-fakegem
-
-DESCRIPTION="Pry is a powerful alternative to the standard IRB shell for Ruby"
-HOMEPAGE="https://github.com/pry/pry/wiki"
-SRC_URI="https://github.com/pry/pry/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE=""
-SLOT="ruby19"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
-
-ruby_add_rdepend "
-       >=dev-ruby/coderay-1.1.0 =dev-ruby/coderay-1.1*
-       >=dev-ruby/method_source-0.9.0 =dev-ruby/method_source-0.9*"
-
-ruby_add_bdepend "
-       test? (
-               >=dev-ruby/open4-1.3
-               >=dev-ruby/rake-0.9
-               >=dev-ruby/mocha-1.0
-       )"
-
-all_ruby_prepare() {
-       # Avoid unneeded dependency on git.
-       # Loosen coderay dependency.
-       sed -e '/git ls-files/d' \
-               -e '/coderay/s/~>/>=/' \
-               -e '/bundler/d' \
-               -i ${RUBY_FAKEGEM_GEMSPEC} || die
-       sed -e '/[Bb]undler/d' -e "1irequire 'mocha/api'\ " -i spec/helper.rb || die
-       # Out of date tests
-       rm spec/commands/gist_spec.rb || die
-}