net-mail/vpopmail: limit upgrade warnings to affected versions
authorRolf Eike Beer <eike@sf-mail.de>
Tue, 22 Oct 2019 14:50:21 +0000 (16:50 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 23 Oct 2019 13:46:25 +0000 (16:46 +0300)
Signed-off-by: Rolf Eike Beer <eike@sf-mail.de>
Closes: https://github.com/gentoo/gentoo/pull/13382
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-mail/vpopmail/vpopmail-5.4.33-r4.ebuild

index 3cbfe467136a5f8882274fb8dd396370724c6efb..fc5ea8ec421953f1dfd2e3c16acd906995b4d2e8 100644 (file)
@@ -217,14 +217,16 @@ pkg_postrm() {
 }
 
 upgradewarning() {
-       ewarn
-       ewarn "Massive important warning if you are upgrading to 5.2.1-r8 or older"
-       ewarn "The internal structure of the mail storage has changed for"
-       ewarn "consistancy with the rest of Gentoo! Please review and utilize the "
-       ewarn "script at ${VPOP_HOME}/bin/vpopmail-Maildir-dotmaildir-fix.sh"
-       ewarn "to upgrade your system! (It can do conversions both ways)."
-       ewarn "You should be able to run it right away without any changes."
-       ewarn
+       if has_version "<=net-mail/vpopmail-5.2.1-r8"; then
+               ewarn
+               ewarn "Massive important warning if you are upgrading to 5.2.1-r8 or older"
+               ewarn "The internal structure of the mail storage has changed for"
+               ewarn "consistancy with the rest of Gentoo! Please review and utilize the "
+               ewarn "script at ${VPOP_HOME}/bin/vpopmail-Maildir-dotmaildir-fix.sh"
+               ewarn "to upgrade your system! (It can do conversions both ways)."
+               ewarn "You should be able to run it right away without any changes."
+               ewarn
+       fi
 
        elog
        elog "Use of vpopmail's tcp.smtp[.cdb] is also deprecated now, consider"
@@ -232,10 +234,12 @@ upgradewarning() {
        elog
 
        if use mysql; then
-               elog
-               elog "If you are upgrading from 5.4.17 or older, you have to fix your"
-               elog "MySQL tables, please see the UPGRADE file in the documentation!"
-               elog
+               if has_version "<=net-mail/vpopmail-5.4.17"; then
+                       elog
+                       elog "If you are upgrading from 5.4.17 or older, you have to fix your"
+                       elog "MySQL tables, please see the UPGRADE file in the documentation!"
+                       elog
+               fi
        fi
 
        ewarn