dev-php/pecl-haru: Drop USE png, zlib
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 12 Jun 2019 12:49:37 +0000 (14:49 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 12 Jun 2019 12:50:20 +0000 (14:50 +0200)
media-libs/libharu-2.3.0-r2 lost these flags for some reason.

Package-Manager: Portage-2.3.67, Repoman-2.3.14
RepoMan-Options: --force
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-php/pecl-haru/pecl-haru-1.0.4-r3.ebuild [new file with mode: 0644]

diff --git a/dev-php/pecl-haru/pecl-haru-1.0.4-r3.ebuild b/dev-php/pecl-haru/pecl-haru-1.0.4-r3.ebuild
new file mode 100644 (file)
index 0000000..44313c4
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php5-6"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="An interface to libharu, a PDF generator"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libharu[png(+),zlib(+)]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+       # config.m4 is broken checking paths, so we need to override it
+       local PHP_EXT_ECONF_ARGS=(
+               --with-png-dir=/usr
+               --with-zlib-dir=/usr
+       )
+
+       php-ext-source-r3_src_configure
+}