games-board/stockfish: port to proper cpu_flags_arm use flag
authorMatthias Maier <tamiko@gentoo.org>
Fri, 28 Feb 2020 01:07:18 +0000 (19:07 -0600)
committerMatthias Maier <tamiko@gentoo.org>
Fri, 28 Feb 2020 01:07:18 +0000 (19:07 -0600)
Closes: https://bugs.gentoo.org/694098
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
games-board/stockfish/metadata.xml
games-board/stockfish/stockfish-10.ebuild

index 38f3f419b3a3663dbb8882046ba1943df42817e1..2ffc98e206f0dac0569afeceba48564b2f99bb90 100644 (file)
@@ -6,7 +6,6 @@
                <name>Matthias Maier</name>
        </maintainer>
        <use>
-               <flag name="armv7">Build for armv7; enables PIE</flag>
                <flag name="general-32">Generic unoptimized 32-bits build</flag>
                <flag name="general-64">Generic unoptimized 64-bits build</flag>
                <flag name="optimize">Enable upstream -O3 optimizations (default enabled)</flag>
index f507eeb1a674bae71a0e855299e2f9ccc352f096..5974776f35e1297b80174c63ba5afa8612d25923 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -12,7 +12,7 @@ SRC_URI="https://stockfish.s3.amazonaws.com/${P}-src.zip"
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="amd64 x86"
-IUSE="armv7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse debug
+IUSE="cpu_flags_arm_v7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse debug
        general-32 general-64 +optimize"
 
 DEPEND="|| ( app-arch/unzip app-arch/zip )"
@@ -47,7 +47,7 @@ src_compile() {
        use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
 
        # other architectures
-       use armv7 && my_arch=armv7
+       use cpu_flags_arm_v7 && my_arch=armv7
        use ppc && my_arch=ppc
        use ppc64 && my_arch=ppc64