kde-base/kstartupconfig -> kde-plasma/kstartupconfig
authorJohannes Huber <johu@gentoo.org>
Mon, 28 Nov 2016 10:11:00 +0000 (11:11 +0100)
committerJohannes Huber <johu@gentoo.org>
Mon, 28 Nov 2016 10:11:33 +0000 (11:11 +0100)
kde-base/kdebase-startkde/kdebase-startkde-4.11.22-r2.ebuild
kde-plasma/kstartupconfig/Manifest [moved from kde-base/kstartupconfig/Manifest with 100% similarity]
kde-plasma/kstartupconfig/kstartupconfig-4.11.22.ebuild [moved from kde-base/kstartupconfig/kstartupconfig-4.11.22.ebuild with 60% similarity]
kde-plasma/kstartupconfig/metadata.xml [moved from kde-base/kstartupconfig/metadata.xml with 55% similarity]
profiles/updates/4Q-2016
x11-libs/libfakekey/@ [new file with mode: 0644]

index 7c7c8df7e5b433f4ad50d15be91358c2eb986f93..721d4194257d4540428d714c9961da9d37cff700 100644 (file)
@@ -56,9 +56,9 @@ RDEPEND="
        $(add_kdebase_dep krunner)
        $(add_kdebase_dep ksmserver)
        $(add_kdebase_dep ksplash)
-       $(add_kdebase_dep kstartupconfig)
        $(add_kdebase_dep plasma-workspace)
        kde-plasma/kcminit:4
+       kde-plasma/kstartupconfig:4
        kde-plasma/kwin:4
        kde-plasma/systemsettings:4
        x11-apps/mkfontdir
similarity index 60%
rename from kde-base/kstartupconfig/kstartupconfig-4.11.22.ebuild
rename to kde-plasma/kstartupconfig/kstartupconfig-4.11.22.ebuild
index 2e35f630907dda5adb6d18458e49e8e1b0ce86d0..0b38ac1b9022c251cda6596daf2e371d10aef835 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -7,6 +7,6 @@ EAPI=5
 KMNAME="kde-workspace"
 inherit kde4-meta
 
-DESCRIPTION="KDE: Utility to launch applications with special window properties"
+DESCRIPTION="Utility to launch applications with special window properties"
 KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
 IUSE="debug"
similarity index 55%
rename from kde-base/kstartupconfig/metadata.xml
rename to kde-plasma/kstartupconfig/metadata.xml
index 0cf59224b0096e033aa6d04930d5ad55e6f29a86..2fdbf33d963db81228cb30a4f1abf67dbe9c29f1 100644 (file)
@@ -1,8 +1,8 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<maintainer type="project">
-       <email>kde@gentoo.org</email>
-       <name>Gentoo KDE Project</name>
-</maintainer>
+       <maintainer type="project">
+               <email>kde@gentoo.org</email>
+               <name>Gentoo KDE Project</name>
+       </maintainer>
 </pkgmetadata>
index 36784bd0bd7cf13aa8042581a832ee1c5c3c3257..c0065d8334a232b82d2d210565930b1c15ddc5ec 100644 (file)
@@ -37,3 +37,4 @@ move kde-base/libkgreeter kde-plasma/libkgreeter
 move kde-base/liboxygenstyle kde-plasma/liboxygenstyle
 move kde-base/kstyles kde-plasma/kstyles
 move kde-base/ksystraycmd kde-plasma/ksystraycmd
+move kde-base/kstartupconfig kde-plasma/kstartupconfig
diff --git a/x11-libs/libfakekey/@ b/x11-libs/libfakekey/@
new file mode 100644 (file)
index 0000000..90a07a3
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Helper library for the x11-misc/matchbox-keyboard package"
+HOMEPAGE="http://matchbox-project.org/"
+SRC_URI="http://matchbox-project.org/sources/${PN}/${PV}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE="debug doc"
+
+RDEPEND="x11-libs/libXtst"
+
+DEPEND="${RDEPEND}
+       doc? ( app-doc/doxygen )"
+
+src_prepare() {
+       # Allow configure to use libtool-2
+       epatch "${FILESDIR}/${P}-ac.patch"
+
+       # Fix underlinking bug #367595
+       sed -i -e 's/^fakekey_test_LDADD=/fakekey_test_LDADD=-lX11 /' \
+               tests/Makefile.am || die 'Cannot sed Makefile.am'
+       sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+       eautoreconf
+}
+
+src_configure() {
+       # --with/without-x is ignored by configure script and X is used.
+       econf   --with-x \
+               $(use_enable debug) \
+               $(use_enable doc doxygen-docs)
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+
+       dodoc AUTHORS ChangeLog INSTALL NEWS README
+       use doc && dohtml doc/html/*
+}