dev-python/ansicolor: Add python3_{7,8}
authorLucian Poston <lucianposton@pm.me>
Tue, 25 Feb 2020 21:11:01 +0000 (15:11 -0600)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 27 Feb 2020 13:54:42 +0000 (15:54 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Lucian Poston <lucianposton@pm.me>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/ansicolor/ansicolor-0.2.6-r1.ebuild [new file with mode: 0644]
dev-python/ansicolor/ansicolor-9999.ebuild

diff --git a/dev-python/ansicolor/ansicolor-0.2.6-r1.ebuild b/dev-python/ansicolor/ansicolor-0.2.6-r1.ebuild
new file mode 100644 (file)
index 0000000..25c1032
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
+       # pypi tars don't include tests and github repo is missing release tags,
+       # so only enabling tests for 9999 at this time
+       distutils_enable_tests pytest
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Produce ansi color output and colored highlighting and diffing"
+HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansicolor/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
index e5f2a4f1961f54adc7691a7a114288da2cc1613d..25c10321fe62ab2825ee9c2a878b8877f2459d89 100644 (file)
@@ -1,27 +1,25 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
 
-inherit distutils-r1 git-r3
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
+       # pypi tars don't include tests and github repo is missing release tags,
+       # so only enabling tests for 9999 at this time
+       distutils_enable_tests pytest
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
 
 DESCRIPTION="Produce ansi color output and colored highlighting and diffing"
 HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansicolor/"
-EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
 
 LICENSE="Apache-2.0"
 SLOT="0"
-KEYWORDS=""
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-python_test() {
-       py.test -v || die "Test suite failed with ${EPYTHON}"
-}