dev-libs/ptexenc: Version bump (v1.3.8_p20200406)
authorMikle Kolyada <zlogene@gentoo.org>
Mon, 13 Apr 2020 06:16:19 +0000 (09:16 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Mon, 13 Apr 2020 06:17:54 +0000 (09:17 +0300)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-libs/ptexenc/Manifest
dev-libs/ptexenc/ptexenc-1.3.7_p20190410.ebuild
dev-libs/ptexenc/ptexenc-1.3.8_p20200406.ebuild [new file with mode: 0644]

index 3318fe46b7ff51fd3cd762f0c32596e70636f990..6484dc0de8ae197ead21356cdc3076da2ee27cf9 100644 (file)
@@ -1 +1,2 @@
 DIST texlive-20190410-source.tar.xz 53783408 BLAKE2B 8e34c7c2b74eab1c4d16ddbf7eddd8566593e6d68c42a2634760f11d86e68970698d8b9deddcf3297966968ede11ecf30e0b04ec19b708dc3e6d0a2abcc3799d SHA512 7759d8e668e53c0c73e48907096da9d8fb6384dd9c3342ddfb05e17d077054c5351d35256cf4e63a6da502de2f09f521979bede7209cdd5bd8ae80eba0efed2e
+DIST texlive-20200406-source.tar.xz 55383320 BLAKE2B 3bc024166ebfc269389531c7cf818b062856cd2dcc27cf0a2e790f07cd941d9905c9c6a54566ea627ea1ca334d2b6da8d3e5bd1c686dc9d6f8ac15aac388c1e3 SHA512 65be52cb5e1b52f12feb62c6cf23e56c581b9dccb8d3b9ccc85c12c62b0cb67dd71de8d22d967d2cbf8403502c66bccb238523d13a0d081be104fc9f9c68b477
index 60b3803d49b6e8f73200d33312acfb0e98cf5bba..f1168e08481184ece3d28901ed76ededc775474d 100644 (file)
@@ -40,7 +40,7 @@ src_configure() {
 
 src_install() {
        default
-       find "${D}" -name '*.la' -delete
+       find "${D}" -name '*.la' -delete || die
 
        insinto /usr/include/ptexenc
        doins ptexenc/unicode-jp.h
diff --git a/dev-libs/ptexenc/ptexenc-1.3.8_p20200406.ebuild b/dev-libs/ptexenc/ptexenc-1.3.8_p20200406.ebuild
new file mode 100644 (file)
index 0000000..63b41c0
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit libtool
+
+DESCRIPTION="Library for Japanese pTeX providing a better way of handling character encodings"
+HOMEPAGE="http://tutimura.ath.cx/ptexlive/?ptexenc"
+SRC_URI="mirror://gentoo/texlive-${PV#*_p}-source.tar.xz"
+# http://tutimura.ath.cx/~nob/tex/ptexlive/ptexenc/${P}.tar.xz
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="iconv static-libs"
+
+DEPEND="iconv? ( virtual/libiconv )
+       dev-libs/kpathsea"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
+
+src_prepare() {
+       default
+
+       # https://bugs.gentoo.org/show_bug.cgi?id=377141
+       sed -i '/^LIBS/s:@LIBS@:@LIBS@ @KPATHSEA_LIBS@:' "${S}"/Makefile.in || die
+
+       cd "${WORKDIR}/texlive-${PV#*_p}-source"
+       S="${WORKDIR}/texlive-${PV#*_p}-source" elibtoolize #sane .so versionning on gfbsd
+}
+
+src_configure() {
+       econf \
+               --with-system-kpathsea \
+               $(use_enable static-libs static) \
+               $(use_enable iconv kanji-iconv)
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+
+       insinto /usr/include/ptexenc
+       doins ptexenc/unicode-jp.h
+       use iconv && doins ptexenc/kanjicnv.h
+
+       dodoc ChangeLog README
+}