xfce-base/xfce4-settings: fix HDMI power cycling bug
authorJason Zaman <perfinion@gentoo.org>
Sun, 13 Sep 2015 11:53:59 +0000 (19:53 +0800)
committerJason Zaman <perfinion@gentoo.org>
Sun, 13 Sep 2015 11:54:29 +0000 (19:54 +0800)
Thanks to Micke Eriksson for testing

Gentoo-Bug: https://bugs.gentoo.org/553896

Package-Manager: portage-2.2.20.1

xfce-base/xfce4-settings/files/xfce4-settings-4.12.0-HDMI-power-cycling.patch [new file with mode: 0644]
xfce-base/xfce4-settings/xfce4-settings-4.12.0-r1.ebuild [new file with mode: 0644]

diff --git a/xfce-base/xfce4-settings/files/xfce4-settings-4.12.0-HDMI-power-cycling.patch b/xfce-base/xfce4-settings/files/xfce4-settings-4.12.0-HDMI-power-cycling.patch
new file mode 100644 (file)
index 0000000..895dd58
--- /dev/null
@@ -0,0 +1,15 @@
+From https://bugzilla.xfce.org/show_bug.cgi?id=11107#c3
+
+diff --git a/xfsettingsd/displays.c b/xfsettingsd/displays.c
+index 3497804..449500b 100644
+--- a/xfsettingsd/displays.c
++++ b/xfsettingsd/displays.c
+@@ -368,7 +368,7 @@ xfce_displays_helper_reload (XfceDisplaysHelper *helper)
+     xfsettings_dbg (XFSD_DEBUG_DISPLAYS, "Refreshing RandR cache.");
+     /* Free the caches */
+-    g_ptr_array_unref (helper->outputs);
++    g_ptr_array_free (helper->outputs, TRUE);
+     g_ptr_array_unref (helper->crtcs);
+     gdk_error_trap_push ();
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.12.0-r1.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.12.0-r1.ebuild
new file mode 100644 (file)
index 0000000..562a627
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Configuration system for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug libcanberra libinput libnotify upower +xklavier"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+       >=dev-libs/glib-2.24
+       media-libs/fontconfig
+       >=x11-libs/gtk+-2.20:2
+       x11-libs/libX11
+       >=x11-libs/libXcursor-1.1
+       >=x11-libs/libXi-1.3
+       >=x11-libs/libXrandr-1.2
+       >=xfce-base/garcon-0.2
+       >=xfce-base/exo-0.8
+       >=xfce-base/libxfce4ui-4.11
+       >=xfce-base/libxfce4util-4.11
+       >=xfce-base/xfconf-4.10
+       libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
+       libinput? ( x11-drivers/xf86-input-libinput )
+       libnotify? ( >=x11-libs/libnotify-0.7 )
+       upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )
+       xklavier? ( >=x11-libs/libxklavier-5 )"
+DEPEND="${RDEPEND}
+       dev-util/intltool
+       virtual/pkgconfig
+       sys-devel/gettext
+       >=x11-proto/inputproto-1.4
+       x11-proto/xproto"
+
+pkg_setup() {
+       XFCONF=(
+               $(use_enable upower upower-glib)
+               $(use_enable libinput xorg-libinput)
+               $(use_enable libnotify)
+               $(use_enable xklavier libxklavier)
+               $(use_enable libcanberra sound-settings)
+               $(xfconf_use_debug)
+               )
+
+       DOCS=( AUTHORS ChangeLog NEWS TODO )
+
+       PATCHES=( "${FILESDIR}/${P}-HDMI-power-cycling.patch" )
+}