media-gfx/greycstoration: Fix gcc6 support, bug #594140 by Peter Levine
authorPacho Ramos <pacho@gentoo.org>
Tue, 4 Apr 2017 12:14:49 +0000 (14:14 +0200)
committerPacho Ramos <pacho@gentoo.org>
Tue, 4 Apr 2017 12:18:28 +0000 (14:18 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

media-gfx/greycstoration/files/greycstoration-2.9-gcc6.patch [new file with mode: 0644]
media-gfx/greycstoration/files/greycstoration-2.9-libpng14.patch
media-gfx/greycstoration/greycstoration-2.9-r2.ebuild [moved from media-gfx/greycstoration/greycstoration-2.9-r1.ebuild with 77% similarity]

diff --git a/media-gfx/greycstoration/files/greycstoration-2.9-gcc6.patch b/media-gfx/greycstoration/files/greycstoration-2.9-gcc6.patch
new file mode 100644 (file)
index 0000000..5b957c6
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/plugins/greycstoration.h 2016-09-22 22:46:42.907946423 -0400
++++ b/plugins/greycstoration.h 2016-09-22 22:49:56.439530308 -0400
+@@ -454,7 +454,7 @@
+       p.temporary = 0;
+       p.counter = 0;
+       p.tile = p.tile_border = p.thread = p.nb_threads = 0;
+-      p.stop_request = false;
++      p.stop_request = NULL;
+       greycstoration_mutex_destroy(p);
+     }
+     p.is_running = false;
index e8c0276f891744b0abac3e2bce132a12890711d9..087f20fb8756012dcef5cab23c053341399f6fe5 100644 (file)
@@ -1,7 +1,7 @@
 http://repos.archlinux.org/wsvn/community/greycstoration/trunk/libpng14.patch
 
---- CImg.h
-+++ CImg.h
+--- a/CImg.h
++++ b/CImg.h
 @@ -25671,7 +25671,7 @@
        png_read_info(png_ptr,info_ptr);
        png_uint_32 W, H;
similarity index 77%
rename from media-gfx/greycstoration/greycstoration-2.9-r1.ebuild
rename to media-gfx/greycstoration/greycstoration-2.9-r2.ebuild
index dac64f5350cce20742fb6a81b320d6a1e5a47c64..393b930c5b2888414317c3b3637f786773f38b7f 100644 (file)
@@ -1,9 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-
-inherit eutils toolchain-funcs
+EAPI=6
+inherit toolchain-funcs
 
 DESCRIPTION="Image regularization algorithm for denoising, inpainting and resizing"
 HOMEPAGE="http://www.greyc.ensicaen.fr/~dtschump/greycstoration/"
@@ -18,23 +17,29 @@ RDEPEND="
        x11-libs/libX11
        x11-libs/libXext
        x11-libs/libXrandr
-       fftw? ( >=sci-libs/fftw-3 )
-       imagemagick? ( media-gfx/imagemagick )
-       jpeg? ( virtual/jpeg )
+       fftw? ( >=sci-libs/fftw-3:3.0= )
+       imagemagick? ( media-gfx/imagemagick:0= )
+       jpeg? ( virtual/jpeg:0 )
        lapack? ( virtual/lapack )
-       png? ( >=media-libs/libpng-1.4 )
-       tiff? ( media-libs/tiff )"
+       png? ( >=media-libs/libpng-1.4:0= )
+       tiff? ( media-libs/tiff:0 )
+"
 DEPEND="${RDEPEND}
        app-arch/unzip
        fftw? ( virtual/pkgconfig )
        lapack? ( virtual/pkgconfig )
-       png? ( virtual/pkgconfig )"
+       png? ( virtual/pkgconfig )
+"
 
-S=${WORKDIR}/GREYCstoration-${PV}/src
+S="${WORKDIR}/GREYCstoration-${PV}/src"
 
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-libpng14.patch
+PATCHES=(
+       "${FILESDIR}"/${P}-libpng14.patch
+       "${FILESDIR}"/${P}-gcc6.patch
+)
 
+src_prepare() {
+       default
        sed -i \
                -e "s:../CImg.h:CImg.h:" \
                greycstoration.cpp || die