Fix build with KV_OUT thanks to Stefan Talpalaru <stefantalpalaru@yahoo.com> in bug...
authorStefan Schweizer <genstef@gentoo.org>
Fri, 24 Nov 2006 18:01:29 +0000 (18:01 +0000)
committerStefan Schweizer <genstef@gentoo.org>
Fri, 24 Nov 2006 18:01:29 +0000 (18:01 +0000)
Package-Manager: portage-2.1.2_rc2-r1

sys-fs/fuse/ChangeLog
sys-fs/fuse/fuse-2.6.0.ebuild
sys-fs/fuse/fuse-2.6.0_rc1.ebuild

index f481aece2969cfbcb5c5656945e4f1d217cd41f2..09a8e76b3b527bf4033eedcf6e5a32fe6b23c038 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sys-fs/fuse
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.66 2006/11/01 15:57:22 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.67 2006/11/24 18:01:29 genstef Exp $
+
+  24 Nov 2006; Stefan Schweizer <genstef@gentoo.org>
+  -fuse-2.6.0_pre2.ebuild, fuse-2.6.0_rc1.ebuild, -fuse-2.6.0_rc3.ebuild,
+  fuse-2.6.0.ebuild:
+  Fix build with KV_OUT thanks to Stefan Talpalaru <stefantalpalaru@yahoo.com>
+  in bug 156140
 
 *fuse-2.6.0 (01 Nov 2006)
 
index 6747c5d896688d1f235282b27ee9cc1955dc9184..8904ac09da6cdd7ba379ada0ef5985dd28bb237a 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.0.ebuild,v 1.1 2006/11/01 15:57:22 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.0.ebuild,v 1.2 2006/11/24 18:01:29 genstef Exp $
 
 inherit linux-mod eutils libtool
 
@@ -19,7 +19,7 @@ CONFIG_CHECK="@FUSE_FS:fuse"
 BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
                          fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
 BUILD_TARGETS="all"
-ECONF_PARAMS="--with-kernel=${KV_OUT_DIR}"
+ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
 FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
 We will continue, but we wont build the module this time."
 
index 85cd25258b3940ee3a3ddf994faaa903a28511c2..7224093708d571818658dc6d2580f3f32333f3f4 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.0_rc1.ebuild,v 1.6 2006/10/20 03:40:33 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.0_rc1.ebuild,v 1.7 2006/11/24 18:01:29 genstef Exp $
 
 inherit linux-mod eutils libtool
 
@@ -19,7 +19,7 @@ CONFIG_CHECK="@FUSE_FS:fuse"
 BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
                          fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
 BUILD_TARGETS="all"
-ECONF_PARAMS="--with-kernel=${KV_OUT_DIR}"
+ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
 FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
 We will continue, but we wont build the module this time."