In dyn_install(), don't cleanse S from the global environment,
authorZac Medico <zmedico@gentoo.org>
Wed, 21 Nov 2007 10:45:53 +0000 (10:45 -0000)
committerZac Medico <zmedico@gentoo.org>
Wed, 21 Nov 2007 10:45:53 +0000 (10:45 -0000)
in case the user wants to repeat the phase (like with
FEATURES=noauto and the ebuild command). Only cleanse it from
environment.bz2. (trunk r8583)

svn path=/main/branches/2.1.2/; revision=8584

bin/ebuild.sh

index bed1920342ad400bf729e801895f096619e1f323..40f34a65fb7c50015e56b550f21a8e16a695c891 100755 (executable)
@@ -1021,11 +1021,15 @@ dyn_install() {
        # local variables can leak into the saved environment.
        unset f
 
-       # To avoid environment bloat, cleanse variables that are
-       # are no longer needed after src_install().
-       unset S
-
-       save_ebuild_env > environment
+       (
+               # To avoid environment.bz2 bloat, cleanse variables that are
+               # are no longer needed after src_install(). Don't cleanse from
+               # the global environment though, in case the user wants to repeat
+               # this phase (like with FEATURES=noauto and the ebuild command).
+               unset S
+       
+               save_ebuild_env > environment
+       )
        bzip2 -f9 environment
 
        cp "${EBUILD}" "${PF}.ebuild"