Import from sunrise, proxy-maintaining now
authorMarkus Ullmann <jokey@gentoo.org>
Sat, 7 Apr 2007 17:26:45 +0000 (17:26 +0000)
committerMarkus Ullmann <jokey@gentoo.org>
Sat, 7 Apr 2007 17:26:45 +0000 (17:26 +0000)
Package-Manager: portage-2.1.2.3

sys-auth/pam_sha512/ChangeLog [new file with mode: 0644]
sys-auth/pam_sha512/files/digest-pam_sha512-0.1.2 [new file with mode: 0644]
sys-auth/pam_sha512/metadata.xml [new file with mode: 0644]
sys-auth/pam_sha512/pam_sha512-0.1.2.ebuild [new file with mode: 0644]

diff --git a/sys-auth/pam_sha512/ChangeLog b/sys-auth/pam_sha512/ChangeLog
new file mode 100644 (file)
index 0000000..8e9eb1c
--- /dev/null
@@ -0,0 +1,26 @@
+# ChangeLog for sys-auth/pam_sha512
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_sha512/ChangeLog,v 1.1 2007/04/07 17:26:45 jokey Exp $
+
+*pam_sha512-0.1.2 (07 Apr 2007)
+
+  07 Apr 2007; Markus Ullmann <jokey@gentoo.org> +metadata.xml,
+  +pam_sha512-0.1.2.ebuild:
+  Import from sunrise, proxy-maintaining now
+
+  07 Apr 2007; Alessio Cassibba (X-Drum) <swapon@gmail.com>
+  pam_sha512-0.1.2.ebuild:
+  fixed strict aliasing problems, added message in pkg_postinst
+
+  07 Apr 2007; Alessio Cassibba (X-Drum) <swapon@gmail.com>
+  pam_sha512-0.1.2.ebuild:
+  added amd64 keyword
+
+  29 Jan 2007; Christian Faulhammer <opfer@gentoo.org>
+  pam_sha512-0.1.2.ebuild:
+  add some quotes
+
+  28 Jan 2007; Ali Polatel (hawking) <polatel@nerdshack.com>
+  +pam_sha512-0.1.2.ebuild, +metadata.xml:
+  New ebuild for bug 102113 thanks to neuron
+
diff --git a/sys-auth/pam_sha512/files/digest-pam_sha512-0.1.2 b/sys-auth/pam_sha512/files/digest-pam_sha512-0.1.2
new file mode 100644 (file)
index 0000000..f2eb221
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 9d5599bee7a8b5064e16df24f440ceb3 pam_sha512-0.1.2.tar.gz 9981
+RMD160 fbec8d8f1a3e158af1c9dcd99c43060ceaba31dc pam_sha512-0.1.2.tar.gz 9981
+SHA256 137b935b86aaf0ad134801ae57ac2e3542f81bb971acf110f9fc927d920831ef pam_sha512-0.1.2.tar.gz 9981
diff --git a/sys-auth/pam_sha512/metadata.xml b/sys-auth/pam_sha512/metadata.xml
new file mode 100644 (file)
index 0000000..8e98664
--- /dev/null
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>pam</herd>
+<maintainer>
+  <email>jokey@gentoo.org</email>
+  <name>Markus Ullmann</name>
+</maintainer>
+<maintainer>
+  <email>swapon@gmail.com</email>
+  <name>Alessio Cassibba</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-auth/pam_sha512/pam_sha512-0.1.2.ebuild b/sys-auth/pam_sha512/pam_sha512-0.1.2.ebuild
new file mode 100644 (file)
index 0000000..5d33f8f
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_sha512/pam_sha512-0.1.2.ebuild,v 1.1 2007/04/07 17:26:45 jokey Exp $
+
+inherit flag-o-matic pam toolchain-funcs
+
+DESCRIPTION="Pam module to allow authentication via sha512 hash'ed passwords."
+HOMEPAGE="http://hollowtube.mine.nu/wiki/index.php?n=Projects.PamSha512"
+SRC_URI="http://hollowtube.mine.nu/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}
+       app-crypt/hashalot"
+
+src_compile() {
+       # fix strict aliasing problems, using -fno-strict-aliasing
+       append-flags "-fPIC -c -Wall -Wformat-security -fno-strict-aliasing"
+       emake CC="$(tc-getCC)" \
+               LD="$(tc-getLD)" \
+               CFLAGS="${CFLAGS}" || die "emake failed"
+               # CFLAGS="${CFLAGS}" is required
+}
+
+src_install() {
+       dopammod pam_sha512.so
+       dodoc README
+       dosbin hashpass
+}
+
+pkg_postinst() {
+       elog "See /usr/share/doc/${PF}/README.bz2 for configuration info"
+       elog ""
+}
\ No newline at end of file