net-p2p/bitcoind: Add patch for missing <deque> include
authorDavid Seifert <soap@gentoo.org>
Thu, 26 Dec 2019 11:56:49 +0000 (12:56 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 26 Dec 2019 11:56:49 +0000 (12:56 +0100)
Closes: https://bugs.gentoo.org/703228
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
net-p2p/bitcoind/bitcoind-0.16.3.ebuild
net-p2p/bitcoind/bitcoind-0.17.1.ebuild
net-p2p/bitcoind/bitcoind-0.18.0.ebuild
net-p2p/bitcoind/files/bitcoind-0.16.3-missing-include.patch [new file with mode: 0644]

index 9147db4d3e08146b2ff64015d93ddff4a8fe23c4..86589b99be5e15b9348251331bd3c809f24b9143 100644 (file)
@@ -71,6 +71,7 @@ src_prepare() {
 
        local knots_patchdir="${WORKDIR}/${KNOTS_P}.patches/"
 
+       eapply "${FILESDIR}"/${PN}-0.16.3-missing-include.patch
        eapply "${knots_patchdir}/${KNOTS_P}.syslibs.patch"
 
        if use knots; then
index 2f1df22dec839e7ac0fd70172835d7a1744e5da6..f8e1efe4331abf5b8166738875c0c018fbdfeb52 100644 (file)
@@ -71,6 +71,7 @@ src_prepare() {
 
        local knots_patchdir="${WORKDIR}/${KNOTS_P}.patches/"
 
+       eapply "${FILESDIR}"/${PN}-0.16.3-missing-include.patch
        eapply "${knots_patchdir}/${KNOTS_P}.syslibs.patch"
 
        if use knots; then
index d758ec04196923b6f6da8573896c1ae9a263eebe..6b144706f370116994207bc03b4b615336c06776 100644 (file)
@@ -75,6 +75,7 @@ src_prepare() {
 
        local knots_patchdir="${WORKDIR}/${KNOTS_P}.patches/"
 
+       eapply "${FILESDIR}"/${PN}-0.16.3-missing-include.patch
        eapply "${knots_patchdir}/${KNOTS_P}.syslibs.patch"
 
        if use knots; then
diff --git a/net-p2p/bitcoind/files/bitcoind-0.16.3-missing-include.patch b/net-p2p/bitcoind/files/bitcoind-0.16.3-missing-include.patch
new file mode 100644 (file)
index 0000000..f413c32
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/src/httpserver.cpp
++++ b/src/httpserver.cpp
+@@ -13,6 +13,7 @@
+ #include <sync.h>
+ #include <ui_interface.h>
++#include <deque>
+ #include <memory>
+ #include <stdio.h>
+ #include <stdlib.h>