x11-misc/i3lock: Fix compiling with -fno-common
authorJeroen Roovers <jer@gentoo.org>
Sat, 25 Jan 2020 10:35:25 +0000 (11:35 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sat, 25 Jan 2020 10:48:07 +0000 (11:48 +0100)
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Closes: https://bugs.gentoo.org/706286
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
x11-misc/i3lock/files/i3lock-2.12-fno-common.patch [new file with mode: 0644]
x11-misc/i3lock/i3lock-2.12-r2.ebuild [new file with mode: 0644]

diff --git a/x11-misc/i3lock/files/i3lock-2.12-fno-common.patch b/x11-misc/i3lock/files/i3lock-2.12-fno-common.patch
new file mode 100644 (file)
index 0000000..09003b1
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/unlock_indicator.c
++++ b/unlock_indicator.c
+@@ -35,7 +35,7 @@
+ /* The current position in the input buffer. Useful to determine if any
+  * characters of the password have already been entered or not. */
+-int input_position;
++extern int input_position;
+ /* The lock window. */
+ extern xcb_window_t win;
diff --git a/x11-misc/i3lock/i3lock-2.12-r2.ebuild b/x11-misc/i3lock/i3lock-2.12-r2.ebuild
new file mode 100644 (file)
index 0000000..07a68eb
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Simple screen locker"
+HOMEPAGE="https://i3wm.org/i3lock/"
+SRC_URI="https://i3wm.org/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+       >=x11-libs/libxkbcommon-0.5.0[X]
+       dev-libs/libev
+       sys-libs/pam
+       x11-libs/cairo[X,xcb(+)]
+       x11-libs/libxcb[xkb]
+       x11-libs/xcb-util
+       x11-libs/xcb-util-xrm
+"
+DEPEND="
+       ${RDEPEND}
+       virtual/pkgconfig
+"
+DOCS=( CHANGELOG README.md )
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.12-fno-common.patch
+)
+
+src_prepare() {
+       default
+
+       sed -i -e 's:login:system-auth:g' pam/${PN} || die
+}
+
+src_configure() {
+       tc-export CC
+       default
+}
+
+src_install() {
+       default
+       doman ${PN}.1
+}