new release
authorMarinus Schraal <foser@gentoo.org>
Mon, 4 Dec 2006 15:18:48 +0000 (15:18 +0000)
committerMarinus Schraal <foser@gentoo.org>
Mon, 4 Dec 2006 15:18:48 +0000 (15:18 +0000)
Package-Manager: portage-2.1.1-r2

media-libs/fontconfig/ChangeLog
media-libs/fontconfig/files/digest-fontconfig-2.4.2 [new file with mode: 0644]
media-libs/fontconfig/fontconfig-2.4.2.ebuild [new file with mode: 0644]

index 62301a35b34d9d9625fff073c59e6ab8f72b685c..37fa6aae583a073c8643de525bd74f7c8ce9ab82 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for media-libs/fontconfig
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.80 2006/10/20 21:39:31 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.81 2006/12/04 15:18:48 foser Exp $
+
+*fontconfig-2.4.2 (4 Dec 2006)
+
+  04 Dec 2006; Marinus Schraal <foser@gentoo.org> fontconfig-2.4.2.ebuild :
+  New release
 
   20 Oct 2006; Bryan Ã˜stergaard <kloeri@gentoo.org>
   fontconfig-2.3.2-r1.ebuild:
diff --git a/media-libs/fontconfig/files/digest-fontconfig-2.4.2 b/media-libs/fontconfig/files/digest-fontconfig-2.4.2
new file mode 100644 (file)
index 0000000..d281320
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 f035852f521b54677f2b5c9e2f6d54a4 fontconfig-2.4.2.tar.gz 1278340
+RMD160 c953020a5193500080c9eceef47b76e61c41b188 fontconfig-2.4.2.tar.gz 1278340
+SHA256 63a3d6413182817b91eea327b58c243f1865acfc40bef61fc52d2b0431341363 fontconfig-2.4.2.tar.gz 1278340
diff --git a/media-libs/fontconfig/fontconfig-2.4.2.ebuild b/media-libs/fontconfig/fontconfig-2.4.2.ebuild
new file mode 100644 (file)
index 0000000..dae3c0c
--- /dev/null
@@ -0,0 +1,99 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.4.2.ebuild,v 1.1 2006/12/04 15:18:48 foser Exp $
+
+inherit eutils libtool autotools
+
+DESCRIPTION="A library for configuring and customizing font access"
+HOMEPAGE="http://fontconfig.org/"
+SRC_URI="http://fontconfig.org/release/${P}.tar.gz"
+
+LICENSE="fontconfig"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc xml"
+
+RDEPEND=">=media-libs/freetype-2.1.4
+       !xml? ( >=dev-libs/expat-1.95.3 )
+       xml? ( >=dev-libs/libxml2-2.6 )"
+
+DEPEND="${RDEPEND}
+       doc? ( app-text/docbook-sgml-utils )"
+
+src_unpack() {
+
+       unpack ${A}
+
+       cd "${S}"
+       # add docbook switch so we can disable it
+       epatch "${FILESDIR}"/${PN}-2.3.2-docbook.patch
+
+       eautoreconf
+
+       # elibtoolize
+       epunt_cxx #74077
+
+}
+
+src_compile() {
+
+       [ "${ARCH}" == "alpha" -a "${CC}" == "ccc" ] && \
+               die "Dont compile fontconfig with ccc, it doesnt work very well"
+
+       # disable docs only disables local docs generation, they come with the tarball
+       econf $(use_enable doc docs) \
+               $(use_enable doc docbook) \
+               --localstatedir=/var \
+               --with-docdir=/usr/share/doc/${PF} \
+               --with-default-fonts=/usr/share/fonts \
+               --with-add-fonts=/usr/local/share/fonts,/usr/X11R6/lib/X11/fonts \
+               $(use_enable xml libxml2) \
+               || die
+
+       emake -j1 || die
+
+}
+
+src_install() {
+
+       make DESTDIR="${D}" install || die
+
+       insinto /etc/fonts
+       doins "${S}"/fonts.conf
+       newins "${S}"/fonts.conf fonts.conf.new
+
+       cd "${S}"
+       newman doc/fonts-conf.5 fonts-conf.5
+
+       dohtml doc/fontconfig-user.html
+       dodoc doc/fontconfig-user.{txt,pdf}
+
+       if use doc; then
+               doman doc/Fc*.3
+               dohtml doc/fontconfig-devel.html doc
+               dohtml -r doc/fontconfig-devel
+               dodoc doc/fontconfig-devel.{txt,pdf}
+       fi
+
+       dodoc AUTHORS ChangeLog NEWS README
+
+}
+
+pkg_postinst() {
+
+       # Changes should be made to /etc/fonts/local.conf, and as we had
+       # too much problems with broken fonts.conf, we force update it ...
+       # <azarah@gentoo.org> (11 Dec 2002)
+       ewarn "Please make fontconfig configuration changes in /etc/fonts/conf.d/"
+       ewarn "and NOT to /etc/fonts/fonts.conf, as it will be replaced!"
+       mv -f ${ROOT}/etc/fonts/fonts.conf.new ${ROOT}/etc/fonts/fonts.conf
+       rm -f ${ROOT}/etc/fonts/._cfg????_fonts.conf
+
+       if [ "${ROOT}" = "/" ]
+       then
+               ebegin "Creating global font cache..."
+               /usr/bin/fc-cache -s
+               eend $?
+       fi
+
+}