app-editors/nano: Removed old.
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 10 Sep 2018 07:48:44 +0000 (09:48 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 10 Sep 2018 07:49:05 +0000 (09:49 +0200)
Package-Manager: Portage-2.3.49, Repoman-2.3.10

app-editors/nano/Manifest
app-editors/nano/nano-2.9.7.ebuild [deleted file]

index 03bafee5dbc74fa39219ddbad70a0a89126ee8a5..382371bdd808102a44f4ba61b65f361d19310e55 100644 (file)
@@ -1,4 +1,3 @@
 DIST nano-2.8.7.tar.gz 2822417 BLAKE2B 2559497b9aee4d4c3cfc86e8af6a54bc0af58588c7bd1142a0e97c6ce50aed66c3852745b83a457263659e97592f0775dcc94c44d818e20440b6524202bfe49a SHA512 511b57f8fe82872827829bca91f7a8666a6ee75924cf2c853332ddd0467abf281c6d3cbaa5dd208c579cbace5bef23d36bd7b62be116aa2175262ed1d15aaf79
-DIST nano-2.9.7.tar.gz 2913055 BLAKE2B 87e04c50a6485c961dddeb7e4fe4b3defda874eb91f373ae1357afdcafd4c207cdf789d72563fdfecb22eabb8dca29559d8fe8abdb0bd36ba1cae7fdf14b1447 SHA512 b62eda79d5d65e4d2020b22624aca06a891747e0e7eeb7b0698bfd9f90d7d1163240d123b7f727868aac09d815e9835f146f7f16e9cbdd5acd7f55311d4acbb7
 DIST nano-2.9.8.tar.gz 2905951 BLAKE2B 95b78c43a052be68956f5b9493c418c23a9db40b56f709b17217bce257333b69e78e8f8bec191b21df8aa408ce2d3c7d68bc82cf2f785df9b31929f4f41b4325 SHA512 dcc7b074b585135e34339648fc725f54964488813d49fac50cf88c11d7cfcb8514907dbc2631ce7664ab0241717e8c42833e3c037070c80c8e7bee68fc280a2d
 DIST nano-3.0.tar.xz 1508248 BLAKE2B 1af09a02b9a7c2aac5ce48e9df12d682d1b213885330e5e936c674602249ca6227fb190611a03d9253c93749e892c1ef5e9569c72bb7df749b6b0888da90fdcd SHA512 120b606d65672a905e9ef9f3b55381cc62b7929abeaf409ea4af6be9f51b3d038e6e68f082755cbb7e198f0fb5203e0f4796c6c96ebd054d9a2241b313fcdda1
diff --git a/app-editors/nano/nano-2.9.7.ebuild b/app-editors/nano/nano-2.9.7.ebuild
deleted file mode 100644 (file)
index d19e8fe..0000000
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit eutils flag-o-matic
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
-       inherit git-r3 autotools
-else
-       MY_P="${PN}-${PV/_}"
-       SRC_URI="https://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
-
-LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
-       sys-libs/ncurses:0=[static-libs(+)]
-       magic? ( sys-apps/file[static-libs(+)] )
-       nls? ( virtual/libintl )
-       !ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="${RDEPEND}
-       nls? ( sys-devel/gettext )
-       virtual/pkgconfig
-       static? ( ${LIB_DEPEND} )"
-
-src_prepare() {
-       default
-       if [[ ${PV} == "9999" ]] ; then
-               eautoreconf
-       fi
-}
-
-src_configure() {
-       use static && append-ldflags -static
-       local myconf=(
-               --bindir="${EPREFIX}"/bin
-               --htmldir=/trash
-               $(use_enable !minimal color)
-               $(use_enable !minimal multibuffer)
-               $(use_enable !minimal nanorc)
-               --disable-wrapping-as-root
-               $(use_enable magic libmagic)
-               $(use_enable spell speller)
-               $(use_enable justify)
-               $(use_enable debug)
-               $(use_enable nls)
-               $(use_enable unicode utf8)
-               $(use_enable minimal tiny)
-               $(usex ncurses --without-slang $(use_with slang))
-       )
-       case ${CHOST} in
-               *-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
-       esac
-       econf "${myconf[@]}"
-}
-
-src_install() {
-       default
-       # don't use "${ED}" here or things break (#654534)
-       rm -r "${D%/}"/trash || die
-
-       dodoc doc/sample.nanorc
-       docinto html
-       dodoc doc/faq.html
-       insinto /etc
-       newins doc/sample.nanorc nanorc
-       if ! use minimal ; then
-               # Enable colorization by default.
-               sed -i \
-                       -e '/^# include /s:# *::' \
-                       "${ED%/}"/etc/nanorc || die
-       fi
-
-       dosym ../../bin/nano /usr/bin/nano
-}