app-text/jo: Add live ebuild
authorJeroen Roovers <jer@gentoo.org>
Wed, 15 Apr 2020 11:34:28 +0000 (13:34 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 15 Apr 2020 11:37:19 +0000 (13:37 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
app-text/jo/jo-99999.ebuild [new file with mode: 0644]

diff --git a/app-text/jo/jo-99999.ebuild b/app-text/jo/jo-99999.ebuild
new file mode 100644 (file)
index 0000000..430a499
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools bash-completion-r1 git-r3
+
+DESCRIPTION="JSON output from a shell"
+HOMEPAGE="https://github.com/jpmens/jo"
+EGIT_REPO_URI="https://github.com/jpmens/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       export bashcompdir=$(get_bashcompdir)
+       default
+}
+
+src_install() {
+       default
+       mv "${ED}/$(get_bashcompdir)"/jo{.bash,} || die
+}