dev-php/theseer-tokenizer: bump to v1.1.3
authorThomas Deutschmann <whissi@gentoo.org>
Wed, 27 Nov 2019 09:06:00 +0000 (10:06 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Wed, 27 Nov 2019 09:06:35 +0000 (10:06 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-php/theseer-tokenizer/Manifest
dev-php/theseer-tokenizer/theseer-tokenizer-1.1.3.ebuild [new file with mode: 0644]

index f9a07ea9687a3983eadda36baf6a186e812fc927..e15e922ad4c24ff08b4c680f57ad59f2f24fd5ba 100644 (file)
@@ -1 +1,2 @@
 DIST theseer-tokenizer-1.1.0.tar.gz 10163 BLAKE2B b2360f901d60f784db2045912707a8e293a55967d60d4e72168a1c4b0c9a2d5bdb739fbed9bfec02075476e7bf6762eb1cc7e36870b84fcc341b609527579ca2 SHA512 8b500565dc0d6c8513db3aa72a7ee1fa04510a712ce9b0977feccddc6b2dae53825e39182d43508e196f326776115789e81697116418f6f9f63d08f0c05d0543
+DIST theseer-tokenizer-1.1.3.tar.gz 10553 BLAKE2B 4bed1623abe110cec432a97fbd28752618420a188b450c935c77b5771d6986be9a51c8f100fd81a89d892b0c1e2b46b0124e3c35e3cbe2138eee2d520c74933a SHA512 e29fd41b311bac8021f4c0593d79a9c1bde4b6ccf4774e94d27a0e8a97bac3844109f9312c4aab6e239365630394b602b56a084c291dc13fb439dc8ac22944e3
diff --git a/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.3.ebuild b/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.3.ebuild
new file mode 100644 (file)
index 0000000..5e52b63
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Convert tokenized PHP source code into XML and other formats"
+HOMEPAGE="https://github.com/theseer/tokenizer"
+SRC_URI="https://github.com/theseer/tokenizer/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/tokenizer-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+       >=dev-lang/php-7.0:*[tokenizer,xmlwriter]"
+
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+src_prepare() {
+       cp "${FILESDIR}/autoload.php" src/ || die
+       default
+}
+
+src_install() {
+       insinto /usr/share/php/TheSeer/Tokenizer
+       doins src/*.php
+       dodoc README.md
+}
+
+src_test() {
+       phpunit || die "Unit testing failed!"
+}