sci-biology/emboss: Drop old
authorJustin Lecher <jlec@gentoo.org>
Thu, 27 Aug 2015 13:47:31 +0000 (15:47 +0200)
committerJustin Lecher <jlec@gentoo.org>
Thu, 27 Aug 2015 13:47:54 +0000 (15:47 +0200)
obsolets multiple bugs

Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=542274
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=534418
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=521604
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=514014
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=493724
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=406279
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=393311
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=382321
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=378443

Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
sci-biology/emboss/Manifest
sci-biology/emboss/emboss-6.0.1.ebuild [deleted file]
sci-biology/emboss/emboss-6.3.1_p4-r1.ebuild [deleted file]

index c364f2c77e869d32bb5a5518d043e9df4b48534a..42ec060430035a7d7341a52a6e5e68973b707b3d 100644 (file)
@@ -1,4 +1 @@
-DIST EMBOSS-6.0.1.tar.gz 20204153 SHA256 3e352902aa9dab88bf486457ff23794f19398dfc6b550c4bf175dfcad34c233d
-DIST EMBOSS-6.3.1.tar.gz 23572243 SHA256 4f3290600a970c2a23a7e47f884d1fc8156ec40538f7191a6e83e23680d27a8d
 DIST EMBOSS-6.6.0.tar.gz 117962028 SHA256 7184a763d39ad96bb598bfd531628a34aa53e474db9e7cac4416c2a40ab10c6e SHA512 2d28a03381f7dc98d205aa50202fbbac02ad218fc775d86579d310296be124403623484b1907154d915f15cd32a9f8cf16ecfaa6c4a28b362e24dc8e6380b75a WHIRLPOOL 25241e865b1ad4e5459f84a2b0def7cd00a6e2904db714838dfe0533e01f8373cfdd4c78df225f9d2a77ead4cb9998791bd19f46b32e220810ad950fa288b9fe
-DIST emboss-6.3.1_p4.patch.gz 4070 SHA256 61d1b62e3148541d496103711db6526ba76488a0899af2c98264b03bf8d6e24c
diff --git a/sci-biology/emboss/emboss-6.0.1.ebuild b/sci-biology/emboss/emboss-6.0.1.ebuild
deleted file mode 100644 (file)
index 0edfd7a..0000000
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=1
-
-inherit eutils
-
-DESCRIPTION="The European Molecular Biology Open Software Suite - A sequence analysis package"
-HOMEPAGE="http://emboss.sourceforge.net/"
-SRC_URI="ftp://${PN}.open-bio.org/pub/EMBOSS/old/${PV}/EMBOSS-${PV}.tar.gz"
-LICENSE="GPL-2 LGPL-2"
-
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="X png minimal"
-
-DEPEND="
-       X? ( x11-libs/libXt )
-       png? (
-               sys-libs/zlib
-               media-libs/libpng
-               media-libs/gd
-               )
-       !minimal? (
-               sci-biology/primer3
-               sci-biology/clustalw
-               )"
-
-RDEPEND="${DEPEND}
-       !sys-devel/cons"
-
-PDEPEND="
-       !minimal? (
-               sci-biology/aaindex
-               sci-biology/cutg
-               sci-biology/prints
-               sci-biology/prosite
-               sci-biology/rebase
-               sci-biology/transfac
-       )"
-
-S="${WORKDIR}/EMBOSS-${PV}"
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       epatch "${FILESDIR}"/${PN}-5.0.0-as-needed.patch
-
-       local link_string="$(pkg-config --libs x11)"
-       if use png; then
-               link_string="${link_string} -lgd $(pkg-config --libs libpng)"
-       fi
-       sed -e "s:PATCH_PLPLOT:${link_string}:" -i plplot/Makefile.in \
-               || die "Failed to patch ajax Makefile"
-}
-
-src_compile() {
-       local myconf
-       myconf="--includedir=${D}/usr/include/emboss"
-       use X || myconf="${EXTRA_CONF} --without-x"
-       use png || myconf="${EXTRA_CONF} --without-pngdriver"
-
-       econf ${myconf}
-       # Do not install the JEMBOSS component (the --without-java configure option
-       # does not work). JEMBOSS will eventually be available as a separate package.
-       sed -i -e "s/SUBDIRS = plplot ajax nucleus emboss test doc jemboss/SUBDIRS = plplot ajax nucleus emboss test doc/" \
-                       Makefile || die
-       emake || die
-}
-
-src_install() {
-       einstall || die "Failed to install program files."
-
-       dodoc AUTHORS ChangeLog FAQ NEWS README THANKS \
-                       || die "Failed to install documentation."
-       newdoc "${FILESDIR}"/${PN}-README.Gentoo-1 README.Gentoo \
-                       || die "Failed to install Gentoo readme file."
-
-       # Install env file for setting libplplot and acd files path.
-       cat <<- EOF > 22emboss
-               # plplot libs dir
-               PLPLOT_LIB="/usr/share/EMBOSS/"
-               # ACD files location
-               EMBOSS_ACDROOT="/usr/share/EMBOSS/acd"
-       EOF
-       doenvd 22emboss || die "Failed to install environment file."
-
-       # Symlink preinstalled docs to "/usr/share/doc".
-       dosym /usr/share/EMBOSS/doc/manuals /usr/share/doc/${PF}/manuals || die
-       dosym /usr/share/EMBOSS/doc/programs /usr/share/doc/${PF}/programs || die
-       dosym /usr/share/EMBOSS/doc/tutorials /usr/share/doc/${PF}/tutorials || die
-       dosym /usr/share/EMBOSS/doc/html /usr/share/doc/${PF}/html || die
-
-       # Clashes #330507
-       mv "${D}"/usr/bin/{digest,pepdigest} || die
-
-       # Remove useless dummy files from the image.
-       find emboss/data -name dummyfile -delete || die "Failed to remove dummy files."
-
-       # Move the provided codon files to a different directory. This will avoid
-       # user confusion and file collisions on case-insensitive file systems (see
-       # bug #115446). This change is documented in "README.Gentoo".
-       mv "${D}"/usr/share/EMBOSS/data/CODONS{,.orig} || \
-                       die "Failed to move CODON directory."
-
-       # Move the provided restriction enzyme prototypes file to a different name.
-       # This avoids file collisions with versions of rebase that install their
-       # own enzyme prototypes file (see bug #118832).
-       mv "${D}"/usr/share/EMBOSS/data/embossre.equ{,.orig} || \
-                       die "Failed to move enzyme equivalence file."
-}
diff --git a/sci-biology/emboss/emboss-6.3.1_p4-r1.ebuild b/sci-biology/emboss/emboss-6.3.1_p4-r1.ebuild
deleted file mode 100644 (file)
index e8baba4..0000000
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit autotools eutils
-
-MY_PATCH="4"
-
-DESCRIPTION="The European Molecular Biology Open Software Suite - A sequence analysis package"
-HOMEPAGE="http://emboss.sourceforge.net/"
-SRC_URI="
-       ftp://${PN}.open-bio.org/pub/EMBOSS/old/${PV}/EMBOSS-${PV/_p${MY_PATCH}}.tar.gz
-       ftp://${PN}.open-bio.org/pub/EMBOSS/old/${PV}/fixes/patches/patch-1-${MY_PATCH}.gz -> ${P}.patch.gz"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="doc minimal mysql pdf png postgres static-libs X"
-
-DEPEND="
-       dev-libs/expat
-       dev-libs/libpcre:3
-       sci-libs/plplot
-       sys-libs/zlib
-       mysql? ( virtual/mysql )
-       pdf? ( media-libs/libharu )
-       png? (
-               sys-libs/zlib
-               media-libs/libpng
-               media-libs/gd
-               )
-       postgres? ( dev-db/postgresql )
-       !minimal? (
-               sci-biology/primer3
-               sci-biology/clustalw
-               )
-       X? ( x11-libs/libXt )"
-RDEPEND="${DEPEND}
-       !sys-devel/cons"
-PDEPEND="
-       !minimal? (
-               sci-biology/aaindex
-               sci-biology/cutg
-               sci-biology/prints
-               sci-biology/prosite
-               sci-biology/rebase
-               sci-biology/transfac
-               )"
-
-S="${WORKDIR}/EMBOSS-${PV/_p${MY_PATCH}}"
-
-src_prepare() {
-       epatch "${WORKDIR}"/${P}.patch
-       epatch \
-               "${FILESDIR}"/${PV}-unbundle-libs.patch \
-               "${FILESDIR}/${PF}_plcol.patch"
-       eautoreconf
-}
-
-src_configure() {
-       econf \
-               $(use_with X x) \
-               $(use_with png pngdriver "${EPREFIX}/usr") \
-               $(use_with doc docroot "${EPREFIX}/usr") \
-               $(use_with pdf hpdf "${EPREFIX}/usr") \
-               $(use_with mysql mysql "${EPREFIX}/usr/bin/mysql_config") \
-               $(use_with postgres postgresql "${EPREFIX}/usr/bin/pg_config") \
-               $(use_enable amd64 64) \
-               $(use_enable static-libs static) \
-               --without-java \
-               --enable-large \
-               --enable-systemlibs \
-               --includedir="${ED}/usr/include/emboss"
-}
-
-src_install() {
-       einstall || die "Failed to install program files."
-
-       dodoc AUTHORS ChangeLog FAQ NEWS README THANKS
-       sed "s:EPREFIX:${EPREFIX}:g" "${FILESDIR}"/${PN}-README.Gentoo-2 > README.Gentoo && \
-       dodoc README.Gentoo
-
-       # Install env file for setting libplplot and acd files path.
-       cat <<- EOF > 22emboss
-               # plplot libs dir
-               PLPLOT_LIB="${EPREFIX}/usr/share/EMBOSS/"
-               # ACD files location
-               EMBOSS_ACDROOT="${EPREFIX}/usr/share/EMBOSS/acd"
-       EOF
-       doenvd 22emboss
-
-       # Symlink preinstalled docs to "/usr/share/doc".
-       dosym /usr/share/EMBOSS/doc/manuals /usr/share/doc/${PF}/manuals
-       dosym /usr/share/EMBOSS/doc/programs /usr/share/doc/${PF}/programs
-       dosym /usr/share/EMBOSS/doc/tutorials /usr/share/doc/${PF}/tutorials
-       dosym /usr/share/EMBOSS/doc/html /usr/share/doc/${PF}/html
-
-       # Clashes #330507
-       mv "${ED}"/usr/bin/{digest,pepdigest} || die
-
-       # Remove useless dummy files from the image.
-       find emboss/data -name dummyfile -delete || die "Failed to remove dummy files."
-
-       # Move the provided codon files to a different directory. This will avoid
-       # user confusion and file collisions on case-insensitive file systems (see
-       # bug #115446). This change is documented in "README.Gentoo".
-       mv "${ED}"/usr/share/EMBOSS/data/CODONS{,.orig} || \
-                       die "Failed to move CODON directory."
-
-       # Move the provided restriction enzyme prototypes file to a different name.
-       # This avoids file collisions with versions of rebase that install their
-       # own enzyme prototypes file (see bug #118832).
-       mv "${ED}"/usr/share/EMBOSS/data/embossre.equ{,.orig} || \
-                       die "Failed to move enzyme equivalence file."
-}