media-libs/virglrenderer: update live ebuild
authorMatthias Maier <tamiko@gentoo.org>
Sun, 19 Apr 2020 20:40:12 +0000 (15:40 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Sun, 19 Apr 2020 20:44:38 +0000 (15:44 -0500)
Closes: https://bugs.gentoo.org/709984
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
media-libs/virglrenderer/virglrenderer-9999.ebuild

index bbd38bf8dbdfbd1a1a1bdbd82191993a02f724b6..00473eb8188eddce77374b5f47210e1a9e25cdba 100644 (file)
@@ -1,16 +1,16 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="6"
+EAPI="7"
 
-inherit autotools eutils
+inherit eutils meson
 
 if [[ ${PV} == "9999" ]] ; then
        EGIT_REPO_URI="https://anongit.freedesktop.org/git/virglrenderer.git"
        inherit git-r3
 else
-       SRC_URI="mirror://gentoo/${P}.tar.xz"
-       KEYWORDS="~amd64 ~x86"
+       SRC_URI="https://gitlab.freedesktop.org/virgl/${PN}/-/archive/${P}/${PN}-${P}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~x86"
 fi
 
 DESCRIPTION="library used implement a virtual 3D GPU used by qemu"
@@ -18,29 +18,27 @@ HOMEPAGE="https://virgil3d.github.io/"
 
 LICENSE="MIT"
 SLOT="0"
-IUSE="static-libs test"
-RESTRICT="!test? ( test )"
+IUSE="static-libs"
 
-RDEPEND=">=x11-libs/libdrm-2.4.50
+RDEPEND="
+       >=x11-libs/libdrm-2.4.50
        media-libs/libepoxy"
-# We need autoconf-archive for @CODE_COVERAGE_RULES@. #568624
-DEPEND="${RDEPEND}
-       sys-devel/autoconf-archive
-       >=x11-misc/util-macros-1.8
-       test? ( >=dev-libs/check-0.9.4 )"
-
-src_prepare() {
-       default
-       [[ -e configure ]] || eautoreconf
-}
+
+DEPEND="${RDEPEND}"
+
+# Most of the testuiste cannot run in our sandboxed environment, just don't
+# deal with it for now.
+RESTRICT="test"
 
 src_configure() {
-       econf \
-               $(use_enable static-libs static) \
-               $(use_enable test tests)
+       local emesonargs=(
+               -Ddefault_library=$(usex static-libs both shared)
+       )
+
+       meson_src_configure
 }
 
 src_install() {
-       default
+       meson_src_install
        find "${ED}"/usr -name 'lib*.la' -delete
 }