dev-python/pylibmc: add py3.5, doc, drop pypy
authorLouis Sautier <sautier.louis@gmail.com>
Thu, 19 Jan 2017 12:10:02 +0000 (13:10 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 20 Jan 2017 19:20:59 +0000 (20:20 +0100)
Tests fail with pypy as it doesn't have a sys.refcount method.

Package-Manager: Portage-2.3.3, Repoman-2.3.1
Closes: https://github.com/gentoo/gentoo/pull/3539

dev-python/pylibmc/Manifest
dev-python/pylibmc/pylibmc-1.5.1-r1.ebuild [new file with mode: 0644]
dev-python/pylibmc/pylibmc-1.5.1.ebuild

index 83e496cf6f404ce2e440d5e8fad1439321511082..493833d5d217fdf855244b624f01e6fd961819cb 100644 (file)
@@ -1,3 +1,3 @@
 DIST pylibmc-1.4.3.tar.gz 53063 SHA256 44167da299eaec2674eea7f8ebead646e361ad07e242e35b755181f88bab44ff SHA512 562091ecc046e1f4d181071dede056865649704e02d705f5af5845ad003ad775ed006c1431d48b330cf3b9fdeaceec6a6748ea9e120f673f06fdb99ed4953318 WHIRLPOOL 6055d0aee74f7edcc995d4350542cfebadeea97ffb367db8595e63cee6c4e0aae61b56471b619c07a7d289f87a2c1b9f0fa538939d113f1d395ceff3e96a86c4
 DIST pylibmc-1.5.0.tar.gz 53077 SHA256 16255595616a6d78cd786a55cc6431da5b7accf46512df854712a0cdbb3acfaa SHA512 0b89ad56d44205c0a20c5e2b56f70ac5128b46df81b4fcb9c72918b5d32e455dd3d976366872fe1d0acf40b61460d08fa6f30a8fa26977c1d65509e28bbbf80d WHIRLPOOL 3d3b8cd8842a6e0e602b5addfed12db94da4fbfb6d4f215546ca6ba9cfc0b24f5ce333e5f2740ba625a416663097e46dc40749418cc4c1a52f3123a032c4b45f
-DIST pylibmc-1.5.1.tar.gz 59726 SHA256 ecba261859c3e1ba3365389cb4f4dfffb7e02120a9f57a288cacf2f42c45cdd6 SHA512 10c8a8aed676efe703047baae928d2d64b6ee7411225e3407ff3dd7c19d087b66b18a94993eab77a433fd20f896714fe4415858ea79e393e99ed06b76cd1385b WHIRLPOOL 133a78d1e992cbb0498211a811973f3150bdbf59b59c9f9a9e183b724cebb09638b3acca7e3d2a82f9fd54002e56375a15c4936d0d6058189fb430aa25682eb5
+DIST pylibmc-1.5.1.tar.gz 69525 SHA256 18fa39885fce5464977d657185f55e491315b84686533db58054605165fd9b06 SHA512 efc40fae9721a6be589f87b66109132d4656725f718e1d63d7d25b9b27790b7c00fc3c7e4e47235895b7127cebc64229ddb284d23d0d903d3a510da7e1ce4549 WHIRLPOOL 668fd46c7d2a9d30bd5055649095fdcc6d38d739c473f66e23293838034b5b8b15aa982f015b029f0d57487080064de9b19600e172e78968c21d94f048666c82
diff --git a/dev-python/pylibmc/pylibmc-1.5.1-r1.ebuild b/dev-python/pylibmc/pylibmc-1.5.1-r1.ebuild
new file mode 100644 (file)
index 0000000..fdee866
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Libmemcached wrapper written as a Python extension"
+HOMEPAGE="http://sendapatch.se/projects/pylibmc/ https://pypi.python.org/pypi/pylibmc"
+# One image is missing from the doc at PyPI
+# https://github.com/lericson/pylibmc/pull/221
+SRC_URI="https://github.com/lericson/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/libmemcached-0.32"
+# Older sphinx versions fail to compile the doc
+# https://github.com/sphinx-doc/sphinx/issues/3266
+DEPEND="${RDEPEND}
+       doc? ( >=dev-python/sphinx-1.5.1-r1[${PYTHON_USEDEP}] )
+       test? (
+               net-misc/memcached
+               dev-python/nose[${PYTHON_USEDEP}]
+       )"
+
+python_prepare_all() {
+       sed -e "/with-info=1/d" -i setup.cfg || die
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       if use doc; then
+               # This variable is added to sys.path
+               # but it does not seem to be useful
+               PYLIBMC_DIR="." emake -C docs
+               HTML_DOCS=( docs/_build/html/. )
+       fi
+}
+
+python_test() {
+       memcached -d -p 11219 -u nobody -l localhost -P "${T}/m.pid" || die
+       MEMCACHED_PORT=11219 nosetests
+       local ret=${?}
+       kill "$(<"${T}/m.pid")" || die
+       [[ ${ret} == 0 ]] || die "Tests fail with ${EPYTHON}!"
+}
index 9fec59b6ad82d0931d2ffc0a2c60151c9f363d9f..62108a665ff3db89ca181f2c09ded031f523e614 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -9,7 +9,7 @@ inherit distutils-r1
 
 DESCRIPTION="Libmemcached wrapper written as a Python extension"
 HOMEPAGE="http://sendapatch.se/projects/pylibmc/ https://pypi.python.org/pypi/pylibmc"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/lericson/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="BSD"
 SLOT="0"