media-plugins/imlib2_loaders: bump to 1.6.0
authorJoonas Niilola <juippis@gentoo.org>
Sun, 24 Nov 2019 13:15:15 +0000 (15:15 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 24 Nov 2019 13:15:15 +0000 (15:15 +0200)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
media-plugins/imlib2_loaders/Manifest
media-plugins/imlib2_loaders/imlib2_loaders-1.6.0.ebuild [new file with mode: 0644]

index 838e4a11a7a6d224c0fab74a2189c6450bfbc15f..a83d849661f7a8c3959d857c904ddd1aa6055197 100644 (file)
@@ -1 +1,2 @@
 DIST imlib2_loaders-1.5.1.tar.gz 378169 BLAKE2B a65dabb8fb537489fe77fdc7c197ce4fa91dc13a86d1a5bf5aae4fbc9ac65a4194b57de8d49bb0dc2d906b20b7c79aa458d0ba668aa947a847414f377fd3b540 SHA512 a94996091a7f9f1271c19d24e6edebeb34977a4e67b8300897de0e5afd06bb9b209e404dd86ab3f397c6dec64f4985a515986b6b048d2c13416265eb2058a8a6
+DIST imlib2_loaders-1.6.0.tar.gz 375642 BLAKE2B cf1e8ad887d7b56ab828018e85d5fc635509eadd283ebc051671d8b9129adfded12449a5e8d7d52f4a8bd8e877a0585d62562e169be6176d93ded3dec0569e5d SHA512 948e85260ad9379f71d35ed8f98355f25878acef3bffc9add0419b6c3d3f7eec0dd504701d0bd2ad75a1aacba02e08965a5f0327f7a2832369af34b5d23d9179
diff --git a/media-plugins/imlib2_loaders/imlib2_loaders-1.6.0.ebuild b/media-plugins/imlib2_loaders/imlib2_loaders-1.6.0.ebuild
new file mode 100644 (file)
index 0000000..c622880
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Additional image loaders for Imlib2"
+HOMEPAGE="https://www.enlightenment.org/
+       https://sourceforge.net/projects/enlightenment/files/imlib2-src/"
+SRC_URI="https://downloads.sourceforge.net/enlightenment/${P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="eet xcf"
+
+RDEPEND=">=media-libs/imlib2-${PV}
+       eet? ( dev-libs/efl[eet] )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+       local myconf=(
+               --disable-static
+               $(use_enable eet)
+               $(use_enable xcf)
+       )
+
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       V=1 emake install DESTDIR="${D}"
+       einstalldocs
+
+       find "${D}" -name '*.la' -delete || die
+}