Squelch more possible warnings in updates-usbids and disable network cron by default.
authorMike Frysinger <vapier@gentoo.org>
Fri, 13 Apr 2007 09:41:24 +0000 (09:41 +0000)
committerMike Frysinger <vapier@gentoo.org>
Fri, 13 Apr 2007 09:41:24 +0000 (09:41 +0000)
Package-Manager: portage-2.1.2.3

sys-apps/usbutils/ChangeLog
sys-apps/usbutils/files/digest-usbutils-0.72-r4 [new file with mode: 0644]
sys-apps/usbutils/files/usbutils-0.72-update-usbids.patch
sys-apps/usbutils/usbutils-0.72-r4.ebuild [new file with mode: 0644]

index abd85393fc3db5c3562b273812473c235f7f12c5..7a96229a3787bf162e5a51bb86b63d4fa0696d9b 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for sys-apps/usbutils
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/ChangeLog,v 1.52 2007/04/01 00:22:14 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/ChangeLog,v 1.53 2007/04/13 09:41:24 vapier Exp $
+
+*usbutils-0.72-r4 (13 Apr 2007)
+
+  13 Apr 2007; Mike Frysinger <vapier@gentoo.org>
+  files/usbutils-0.72-update-usbids.patch, +usbutils-0.72-r4.ebuild:
+  Squelch more possible warnings in updates-usbids and disable network cron by
+  default.
 
 *usbutils-0.72-r3 (01 Apr 2007)
 
@@ -27,7 +34,7 @@
   10 Feb 2007; Mike Frysinger <vapier@gentoo.org>
   +files/usbutils-0.72-update-usbids.patch, files/usbutils.cron,
   +usbutils-0.72-r1.ebuild:
-  Add a -q (quiet) flag to update-usbids and have th cronjob use it #164800 by
+  Add a -q (quiet) flag to update-usbids and have the cronjob use it #164800 by
   Horst Prote.
 
 *usbutils-0.72 (19 Jan 2007)
diff --git a/sys-apps/usbutils/files/digest-usbutils-0.72-r4 b/sys-apps/usbutils/files/digest-usbutils-0.72-r4
new file mode 100644 (file)
index 0000000..914cebd
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 ee345fe605ffcfce843dae4aed81122b usbutils-0.72.tar.gz 166354
+RMD160 7af32b146e196d1df3de8e403fa92137bfe3d4c7 usbutils-0.72.tar.gz 166354
+SHA256 00385353242173b878413e0423c1dddcbbb50a3cadc3bb9d0a6adcf335794423 usbutils-0.72.tar.gz 166354
index f049c22dccd8bd87566f0d6db75f7983d5ed06f1..fc90773cc9bcd7e10afe638e2b67202ee63153b7 100644 (file)
@@ -1,6 +1,6 @@
 --- update-usbids.sh
 +++ update-usbids.sh
-@@ -2,12 +2,22 @@
+@@ -2,13 +2,23 @@
  
  # see also update-pciids.sh (fancier)
  
 +      exit 0
 +fi
 +
- if which wget >/dev/null ; then
+-if which wget >/dev/null ; then
++if which wget >/dev/null 2>&1 ; then
        DL="wget -O $DEST.new $SRC"
+-elif which lynx >/dev/null ; then
 +      ${quiet} && DL="$DL -q"
- elif which lynx >/dev/null ; then
++elif which lynx >/dev/null 2>&1 ; then
        DL="eval lynx -source $SRC >$DEST.new"
  else
+       echo >&2 "update-usbids: cannot find wget nor lynx"
 @@ -33,4 +43,4 @@
  fi
  mv $DEST.new $DEST
diff --git a/sys-apps/usbutils/usbutils-0.72-r4.ebuild b/sys-apps/usbutils/usbutils-0.72-r4.ebuild
new file mode 100644 (file)
index 0000000..b9283e3
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/usbutils-0.72-r4.ebuild,v 1.1 2007/04/13 09:41:24 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="USB enumeration utilities"
+HOMEPAGE="http://linux-usb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linux-usb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="network-cron"
+
+DEPEND="dev-libs/libusb"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       cp update-usbids.sh update-usbids.sh.orig
+       epatch "${FILESDIR}"/${P}-update-usbids.patch
+
+       # put usb.ids in same place as pci.ids (/usr/share/misc)
+       sed -i \
+               -e 's:/usr/share/usb.ids:/usr/share/misc/usb.ids:' \
+               lsusb.8 || die "sed lsusb.8"
+       sed -e '/^DEST=/s:=usb.ids:=/usr/share/misc/usb.ids:' \
+               update-usbids.sh > update-usbids
+}
+
+src_compile() {
+       econf \
+               --datadir=/usr/share/misc \
+               --enable-usbmodules \
+               || die "./configure failed"
+       emake || die "make failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "install failed"
+       dosbin update-usbids || die "update-usbids failed"
+       dodoc AUTHORS ChangeLog NEWS README
+
+       use network-cron || return 0
+       exeinto /etc/cron.monthly
+       newexe "${FILESDIR}"/usbutils.cron update-usbids || die
+}