mail-client/neomutt: fix configure with ccache
authorMarty E. Plummer <hanetzer@startmail.com>
Tue, 8 Oct 2019 09:46:19 +0000 (04:46 -0500)
committerNicolas Bock <nicolasbock@gentoo.org>
Fri, 11 Oct 2019 12:40:12 +0000 (06:40 -0600)
If you have dev-util/ccache installed but not FEATURES="ccache", neomutt's
configure process will detect and try to use it. You can override this
by setting an env var, CCACHE, to 'none' (and only that, see line 1132
or so of neomutt's source file auto.def).

Without this change, you will get the following sort of error:

>>> Configuring source in /tmp/portage/mail-client/neomutt-20180716/work/neomutt-neomutt-20180716 ...
./configure --prefix=/usr --build=x86_64-pc-linux-gnu ....
Host System...x86_64-pc-linux-gnu
Note: defaultprefix is deprecated. Use options-defaults to set default options
Build System...x86_64-pc-linux-gnu
C compiler...ccache x86_64-pc-linux-gnu-gcc -O2 -pipe -march=znver1
C++ compiler...ccache x86_64-pc-linux-gnu-c++ -O2 -pipe -march=znver1
Build C compiler...cc
 * ACCESS DENIED:  utimes:       /var/cache/ccache

Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Marty E. Plummer <hanetzer@startmail.com>
Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
mail-client/neomutt/neomutt-20180716.ebuild
mail-client/neomutt/neomutt-99999999.ebuild

index ccd0f97bec9f8f42087dd66c56285ea3ad215ae9..e29f859a066fd24ef12c51c07ef7e61df79fe595 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -94,7 +94,7 @@ src_configure() {
                "$(use_enable gnutls)"
        )
 
-       econf "${myconf[@]}"
+       econf CCACHE=none "${myconf[@]}"
 }
 
 src_install() {
index 4d1742196c36c870a677f4bed771394992a9ccf9..e97f8da78b1cf2209183b655957b439d4047f912 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -94,7 +94,7 @@ src_configure() {
                "$(use_enable gnutls)"
        )
 
-       econf "${myconf[@]}"
+       econf CCACHE=none "${myconf[@]}"
 }
 
 src_install() {