net-nds/openldap: fix MissingSlash
authorMikle Kolyada <zlogene@gentoo.org>
Wed, 12 Feb 2020 19:06:29 +0000 (22:06 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Wed, 12 Feb 2020 19:06:59 +0000 (22:06 +0300)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
net-nds/openldap/openldap-2.4.49.ebuild

index d7df0d817e0f9f9173d869b2677aa73fd1944c35..6b4c5ba2ad9396529589f80d68f99c18b3c16776 100644 (file)
@@ -866,7 +866,7 @@ pkg_postinst() {
                # and a misconfiguration if multiple machines use the same key and cert.
                if use ssl; then
                        install_cert /etc/openldap/ssl/ldap
-                       use prefix || chown ldap:ldap "${EROOT}"etc/openldap/ssl/ldap.*
+                       use prefix || chown ldap:ldap "${EROOT}"/etc/openldap/ssl/ldap.*
                        ewarn "Self-signed SSL certificates are treated harshly by OpenLDAP 2.[12]"
                        ewarn "Self-signed SSL certificates are treated harshly by OpenLDAP 2.[12]"
                        ewarn "add 'TLS_REQCERT allow' if you want to use them."
@@ -881,11 +881,11 @@ pkg_postinst() {
                fi
 
                # These lines force the permissions of various content to be correct
-               use prefix || chown ldap:ldap "${EROOT}"var/run/openldap
+               use prefix || chown ldap:ldap "${EROOT}"/var/run/openldap
                chmod 0755 "${EROOT}"var/run/openldap
-               use prefix || chown root:ldap "${EROOT}"etc/openldap/slapd.conf{,.default}
+               use prefix || chown root:ldap "${EROOT}"/etc/openldap/slapd.conf{,.default}
                chmod 0640 "${EROOT}"etc/openldap/slapd.conf{,.default}
-               use prefix || chown ldap:ldap "${EROOT}"var/lib/openldap-data
+               use prefix || chown ldap:ldap "${EROOT}"/var/lib/openldap-data
        fi
 
        if has_version 'net-nds/openldap[-minimal]' && ((${OPENLDAP_PRINT_MESSAGES})); then