dev-python/sympy: Clean py2 deps up
authorMichał Górny <mgorny@gentoo.org>
Tue, 17 Mar 2020 07:39:03 +0000 (08:39 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 17 Mar 2020 08:07:43 +0000 (09:07 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sympy/sympy-1.0-r1.ebuild
dev-python/sympy/sympy-1.3.ebuild
dev-python/sympy/sympy-1.5.1-r1.ebuild
dev-python/sympy/sympy-1.5.1.ebuild
dev-python/sympy/sympy-1.5.ebuild

index a1b4f8b591efb8fee8dd44a367c8fd52125d5a1b..195f59d969c01c2ebdcb749945b622fe0946806a 100644 (file)
@@ -17,12 +17,11 @@ KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 IUSE="examples gtk imaging ipython latex mathml opengl pdf png test texmacs"
 RESTRICT="!test? ( test )"
 
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
-       ipython? ( || ( $(python_gen_useflags -3) ) )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
        imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
-       ipython? ( $(python_gen_cond_dep 'dev-python/ipython[${PYTHON_USEDEP}]' -3) )
+       ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
        latex? (
                virtual/latex-base
                dev-texlive/texlive-fontsextra
index 078dc48e8f85cb17446b8986db6da0b5d516e44d..ffc69e64f9132b8e56dfc8c596ff5053078b1d6d 100644 (file)
@@ -16,8 +16,7 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 IUSE="examples gtk imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
 
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
-       ipython? ( || ( $(python_gen_useflags -3) ) )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RESTRICT="test"
 # All tests actually pass, except a bunch of tests related to the deprecated pygletplot
@@ -26,7 +25,7 @@ RESTRICT="test"
 RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
        dev-python/pexpect[${PYTHON_USEDEP}]
        imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
-       ipython? ( $(python_gen_cond_dep 'dev-python/ipython[${PYTHON_USEDEP}]' -3) )
+       ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
        latex? (
                virtual/latex-base
                dev-texlive/texlive-fontsextra
index cc961486a27df1da039495f14380a6d5f1f6fa30..aed3527e80eea3903913681c42d6f1ab424d9c8f 100644 (file)
@@ -16,8 +16,7 @@ SLOT="0"
 KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 IUSE="examples imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
 
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
-       ipython? ( || ( $(python_gen_useflags -3) ) )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RESTRICT="test"
 # All tests actually pass, except a bunch of tests related to the deprecated pygletplot
@@ -26,7 +25,7 @@ RESTRICT="test"
 RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
        dev-python/pexpect[${PYTHON_USEDEP}]
        imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
-       ipython? ( $(python_gen_cond_dep 'dev-python/ipython[${PYTHON_USEDEP}]' -3) )
+       ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
        latex? (
                virtual/latex-base
                dev-texlive/texlive-fontsextra
index 5ecc82a06a547a8c5d57c9ebec9e56f7e602bbf3..dd759926e28970d65b5296eb2c86e08f3a0d9c5b 100644 (file)
@@ -16,8 +16,7 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 IUSE="examples gtk imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
 
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
-       ipython? ( || ( $(python_gen_useflags -3) ) )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RESTRICT="test"
 # All tests actually pass, except a bunch of tests related to the deprecated pygletplot
@@ -26,7 +25,7 @@ RESTRICT="test"
 RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
        dev-python/pexpect[${PYTHON_USEDEP}]
        imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
-       ipython? ( $(python_gen_cond_dep 'dev-python/ipython[${PYTHON_USEDEP}]' -3) )
+       ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
        latex? (
                virtual/latex-base
                dev-texlive/texlive-fontsextra
index c8dda89674743c42c27fafc063cc6de0f37d775c..3d8957d84cb94fbe6f296bb5c1a128c1cd88373d 100644 (file)
@@ -16,8 +16,7 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 IUSE="examples gtk imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
 
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
-       ipython? ( || ( $(python_gen_useflags -3) ) )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RESTRICT="test"
 # All tests actually pass, except a bunch of tests related to the deprecated pygletplot
@@ -26,7 +25,7 @@ RESTRICT="test"
 RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
        dev-python/pexpect[${PYTHON_USEDEP}]
        imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
-       ipython? ( $(python_gen_cond_dep 'dev-python/ipython[${PYTHON_USEDEP}]' -3) )
+       ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
        latex? (
                virtual/latex-base
                dev-texlive/texlive-fontsextra