dev-python/sqlalchemy-rqlite: Enable py3.{7,8}, modernize
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 11:43:32 +0000 (13:43 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 12:50:50 +0000 (14:50 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sqlalchemy-rqlite/sqlalchemy-rqlite-1.0.ebuild
dev-python/sqlalchemy-rqlite/sqlalchemy-rqlite-9999.ebuild

index 6a9c5db39ea228c5e95eaedff56c1d87792ce37f..be1c7ec7770110549a272cea73ef851c253a874e 100644 (file)
@@ -1,8 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit distutils-r1
 
@@ -18,24 +20,14 @@ SRC_URI="${EGIT_REPO_URI%.git}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="
        dev-python/pyrqlite[${PYTHON_USEDEP}]
-       dev-python/sqlalchemy[${PYTHON_USEDEP}]
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-cov[${PYTHON_USEDEP}]
-               dev-python/pylint[${PYTHON_USEDEP}]
-       )"
+       dev-python/sqlalchemy[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
 
 src_prepare() {
        sed -e "s:^__version__ = .*:__version__ = '${PV}':" -i src/sqlalchemy_rqlite/constants.py || die
        distutils-r1_src_prepare
 }
-
-python_test() {
-       esetup.py test || die "tests failed"
-       esetup.py lint -f text -E || die "pylint failed"
-}
index 8e6f856291344d2d8abb643d5f0e09db58817f27..76e6ab45fc9474e43ae46a4e499b2f8e9ed14bb5 100644 (file)
@@ -1,8 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit distutils-r1
 
@@ -17,24 +19,14 @@ HOMEPAGE="https://github.com/rqlite/sqlalchemy-rqlite"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS=""
-IUSE="test"
-RESTRICT="!test? ( test )"
 
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="
        dev-python/pyrqlite[${PYTHON_USEDEP}]
-       dev-python/sqlalchemy[${PYTHON_USEDEP}]
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-cov[${PYTHON_USEDEP}]
-               dev-python/pylint[${PYTHON_USEDEP}]
-       )"
+       dev-python/sqlalchemy[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
 
 src_prepare() {
        sed -e "s:^__version__ = .*:__version__ = '${PV}':" -i src/sqlalchemy_rqlite/constants.py || die
        distutils-r1_src_prepare
 }
-
-python_test() {
-       esetup.py test || die "tests failed"
-       esetup.py lint -f text -E || die "pylint failed"
-}