dev-util/nvidia-cuda-toolkit: Bump to 10.1.105
authorJan Vesely <jano.vesely@gmail.com>
Sat, 23 Mar 2019 06:41:21 +0000 (02:41 -0400)
committerJason Zaman <perfinion@gentoo.org>
Fri, 5 Apr 2019 15:38:31 +0000 (23:38 +0800)
Other changes:
Bump to EAPI=7
Don't use versionator
Update SRC_URI file name
Don't unpack the source file twice
Use dobin + doins instead of mv

v2: move to toolkit directory before considering docs
v3: remove more gdb/profiler/eclipse content

Closes: https://github.com/gentoo/gentoo/pull/11481
Closes: https://bugs.gentoo.org/681694
Signed-off-by: Jan Vesely <jano.vesely@gmail.com>
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
dev-util/nvidia-cuda-toolkit/Manifest
dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-10.1.105.ebuild [new file with mode: 0644]

index 64438f71631c144f787152d7a874c4840a7a9ab7..c6ef0b44ee5080fff28651d2e712730f8b314827 100644 (file)
@@ -1,4 +1,5 @@
 DIST cuda_10.0.130_410.48_linux.run 2020126691 BLAKE2B f784f41c06d81b6f89d07e756347fb94148f79e5fd50650fc340feb6b49dcc2bedd05cf4c7c2662da39955f9393efc048aa17fa921aad86e182186fb6d98ec50 SHA512 409ea4cc6aa0fe7063450e77c3b67b9b41aab1bbe556db673fb1a80610b20bd52e2020bf94034a92ab68c721d3d5739500bae4bd7a3558b2d8e73730a3b4ea25
+DIST cuda_10.1.105_418.39_linux.run 2423314285 BLAKE2B 924872eaaa4e8ecd6b81765c91d5e538d968e4fc88792a805339dd9cae15dd70372f310d39b9668d76cadbab875e3c4abcfca5a5cf71e4d83c9db056dc02f51c SHA512 07cdc053989758e4cdccaad566cae7127fa79780ad85033ea52d33cc4c43c9de08e88dd087390c58b542e51703f256859cdf51a018ee57e6a412f45fb9561622
 DIST cuda_6.5.14_linux_32.run 76788277 BLAKE2B 75e79dce6cac5155bde8a3cafa945047c489b10272f8a3b94bf55d499df4b9c8b82506a81a20f9fd816bd4fd0514e515a6435399db1cb62b027c76490bd4dfae SHA512 89649ee0f4543b37037b7c8f5ed0b8bd502512afb4d93e3158b3df4786123be05a5288986b5abbfe15c14eb010777d2527b715225bea96a354a898c34e4a2fcc
 DIST cuda_6.5.14_linux_64.run 972320904 BLAKE2B 4a4361fb7a90989ec4b4aa433189e7b358e5a2272fb9b9c59429e0014ac14e3b8de1b247ee98dc30c3f3ee4cc009eca4fdd86027bd3b9527a683353d60bdf5c6 SHA512 fecca731b86955f5bc7b09d88b02951e3ee5d4b1f1cf5f92658227a029b87cd35d6ac22956a5fa0afe62dcdc57191f1d12bb08c9f7cc05128727cd8455947b1e
 DIST cuda_6.5.19_linux_32.run 81882112 BLAKE2B cf55ef7c969503c156431fc56301ed4e9a1234ae0cb867f12649636069f35e56bf6fc9df7482b6baade45d78c8baa2d98c41a28696da59294e0f575c4a0344ce SHA512 1ce9bd6b472b7e4f1fb181eb340dfcb757714d59a89aaa02146cfe1a97c8ccb7eb7699b4ec823276f277eb4d82d95050eaba17e7ed5fd2e47b9b5d78531c5d4e
diff --git a/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-10.1.105.ebuild b/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-10.1.105.ebuild
new file mode 100644 (file)
index 0000000..0ba04a3
--- /dev/null
@@ -0,0 +1,143 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit check-reqs cuda toolchain-funcs unpacker
+
+MYD=$(ver_cut 1-2 ${PV})
+DRIVER_PV="418.39"
+
+DESCRIPTION="NVIDIA CUDA Toolkit (compiler and friends)"
+HOMEPAGE="https://developer.nvidia.com/cuda-zone"
+SRC_URI="https://developer.nvidia.com/compute/cuda/${MYD}/Prod/local_installers/cuda_${PV}_${DRIVER_PV}_linux.run -> cuda_${PV}_${DRIVER_PV}_linux.run"
+
+LICENSE="NVIDIA-CUDA"
+SLOT="0/${PV}"
+KEYWORDS="-* ~amd64 ~amd64-linux"
+IUSE="debugger doc eclipse profiler"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+       <sys-devel/gcc-9[cxx]
+       >=x11-drivers/nvidia-drivers-396.24[X,uvm]
+       debugger? (
+               sys-libs/libtermcap-compat
+               sys-libs/ncurses:5/5[tinfo]
+               )
+       eclipse? ( >=virtual/jre-1.6 )
+       profiler? ( >=virtual/jre-1.6 )"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="opt/cuda/*"
+
+CHECKREQS_DISK_BUILD="6100M"
+
+pkg_setup() {
+       # We don't like to run cuda_pkg_setup as it depends on us
+       check-reqs_pkg_setup
+}
+
+src_prepare() {
+       local cuda_supported_gcc
+
+       cuda_supported_gcc="4.7 4.8 4.9 5.3 5.4 6.3 6.4 7.2 7.3 8.2 8.3"
+
+       sed \
+               -e "s:CUDA_SUPPORTED_GCC:${cuda_supported_gcc}:g" \
+               "${FILESDIR}"/cuda-config.in > "${T}"/cuda-config || die
+
+       default
+}
+
+src_install() {
+       local i remove=( doc jre run_files install-linux.pl cuda-installer.pl )
+       local cudadir=/opt/cuda
+       local ecudadir="${EPREFIX}${cudadir}"
+
+       cd builds/cuda-toolkit
+       if use doc; then
+               DOCS+=( doc/pdf/. )
+               HTML_DOCS+=( doc/html/. )
+       fi
+       einstalldocs
+
+       mv doc/man/man3/{,cuda-}deprecated.3 || die
+       doman doc/man/man*/*
+
+       use debugger || remove+=( bin/cuda-gdb bin/cuda-gdbserver extras/Debugger share/gdb extras/cuda-gdb-${PV}.src.tar.gz )
+
+       if use profiler; then
+               # hack found in install-linux.pl
+               for i in nvvp nsight; do
+                       cat > bin/${i} <<- EOF || die
+                               #!/usr/bin/env sh
+                               LD_LIBRARY_PATH=\${LD_LIBRARY_PATH}:${ecudadir}/lib:${ecudadir}/lib64 \
+                                       UBUNTU_MENUPROXY=0 LIBOVERLAY_SCROLLBAR=0 \
+                                       ${ecudadir}/lib${i}/${i} -vm ${EPREFIX}/usr/bin/java
+                       EOF
+                       chmod a+x bin/${i} || die
+               done
+       else
+               use eclipse || remove+=( libnvvp libnsight nsightee_plugins NsightCompute-2019.1 NsightSystems-2018.3 bin/nsight bin/nsight_ee_plugins_manage.sh bin/nvvp bin/computeprof )
+               remove+=( extras/CUPTI bin/nvprof )
+       fi
+
+       for i in "${remove[@]}"; do
+               ebegin "Cleaning ${i}..."
+               rm -rf "${i}" || die
+               eend
+       done
+
+       dodir ${cudadir} || die
+       # Install binaries separately to amke sure the X permission is set
+       into ${cudadir} || die
+       dobin $(find bin nvvm/bin -type f) || die
+       find bin nvvm/bin -type f -delete || die
+
+       # Install the rest
+       insinto ${cudadir} || die
+       doins -r * || die
+
+       cat > "${T}"/99cuda <<- EOF || die
+               PATH=${ecudadir}/bin$(usex profiler ":${ecudadir}/libnvvp" "")
+               ROOTPATH=${ecudadir}/bin
+               LDPATH=${ecudadir}/lib64:${ecudadir}/lib:${ecudadir}/nvvm/lib64
+       EOF
+       doenvd "${T}"/99cuda
+
+       use profiler && \
+               make_wrapper nvprof "${ecudadir}/bin/nvprof" "." "${ecudadir}/lib64:${ecudadir}/lib"
+
+       dobin "${T}"/cuda-config
+}
+
+pkg_postinst_check() {
+       local a b
+       a="$(cuda-config -s)"
+       b="0.0"
+       for v in $a; do
+               if ver_test "${v}" -gt "${b}"; then
+                       b="${v}"
+               fi
+       done
+
+       # if gcc and if not gcc-version is at least greatest supported
+       if tc-is-gcc && \
+               ver_test $(gcc-version) -gt ${b}; then
+                       ewarn ""
+                       ewarn "gcc >= ${b} will not work with CUDA"
+                       ewarn "Make sure you set an earlier version of gcc with gcc-config"
+                       ewarn "or append --compiler-bindir= pointing to a gcc bindir like"
+                       ewarn "--compiler-bindir=${EPREFIX}/usr/*pc-linux-gnu/gcc-bin/gcc${b}"
+                       ewarn "to the nvcc compiler flags"
+                       ewarn ""
+       fi
+}
+
+pkg_postinst() {
+       if [[ ${MERGE_TYPE} != binary ]]; then
+               pkg_postinst_check
+       fi
+}