sci-libs/adolc: version bump to 2.7.2
authorMatthias Maier <tamiko@gentoo.org>
Tue, 7 Apr 2020 02:42:23 +0000 (21:42 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Tue, 7 Apr 2020 02:55:07 +0000 (21:55 -0500)
Upstream has released a new version after 3 years.

Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
sci-libs/adolc/Manifest
sci-libs/adolc/adolc-2.7.2.ebuild [new file with mode: 0644]

index a6565ec12f6daf4a8c1978228f2e1f3c5db547af..e037c72c745b99ea28abc6738cb6eda22a2ffc3f 100644 (file)
@@ -1,2 +1,3 @@
 DIST ADOL-C-2.4.1.tgz 2210414 BLAKE2B f9b1fd7f0e619d811b29e077e436697dc8b5a388568d73b2db602e57f97cbb690a5b47a55c722ae45cc28698dd19949eddb9d02e11c87383191e217f012519bb SHA512 5e5135ca587d159510bf77338fdff3d324f4d32c4ec6f8cf64ddc92253b427b8ee26a30bc1d83fe18121bbfdc7454c3536f58849c0c335e1b240e39d46acdccc
 DIST ADOL-C-2.6.3.tgz 2416928 BLAKE2B 74e575a1a919bc2787be0c29deaac4b503c077cb06efdba3f2382f21abf1ed53e8cb5f41729dc39f9188e44460fa137a09cffdb296b5f92131153795f36fa83a SHA512 e3c44b1f8ab5211a8a3c3163124e35b6d1e9551672ab4944d983dd3117f609d512c1b08c61e535dc4d50089295ee565bec07aaca67aa88b57b17bc3906573262
+DIST adolc-2.7.2.tar.gz 2447479 BLAKE2B 0f871ce1dcb50bb14684e45e265cf45807f514dd3ca0dbaaedede2c7117d34cc5a34b0096a34c8ec37023e50aec7fd4be6561819d6297771e7f7fcaa7ba0e507 SHA512 b896650077367fd7388a6c5a40e5d8bb3f19af9e3bc5b067fd1d9a769809b77ccdfb5ef11ef481ab791c0f040401aaed0053cba55d4c2a3383c0d056122280f6
diff --git a/sci-libs/adolc/adolc-2.7.2.ebuild b/sci-libs/adolc/adolc-2.7.2.ebuild
new file mode 100644 (file)
index 0000000..dc6d88c
--- /dev/null
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs eutils
+
+DESCRIPTION="Automatic differentiation system for C/C++"
+HOMEPAGE="https://projects.coin-or.org/ADOL-C/"
+
+if [[ ${PV} = *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/coin-or/ADOL-C"
+       SRC_URI=""
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/coin-or/ADOL-C/archive/releases/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+       S="${WORKDIR}/ADOL-C-releases-${PV}"
+fi
+
+LICENSE="|| ( EPL-1.0 GPL-2 )"
+SLOT="0/2"
+IUSE="+boost mpi sparse static-libs"
+
+RDEPEND="
+       boost? ( dev-libs/boost:0= )
+       mpi? ( sys-cluster/ampi:0= )
+       sparse? ( sci-libs/colpack:0= )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.5.0-no-colpack.patch
+       "${FILESDIR}"/${PN}-2.5.0-pkgconfig-no-ldflags.patch
+       "${FILESDIR}"/${PN}-2.6.2-dash.patch
+)
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --enable-advanced-branching \
+               --enable-atrig-erf \
+               $(use_enable mpi ampi) \
+               $(use_enable sparse) \
+               $(use_enable static-libs static) \
+               $(use_with boost) \
+               $(use_with sparse colpack "${EPREFIX}"/usr)
+}
+
+src_test() {
+       emake test
+}
+
+src_install() {
+       default
+       use static-libs || find "${D}" -name '*.la' -type f -delete || die
+}