sys-libs/openipmi: Bump to version 2.0.24
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 4 Jan 2018 11:20:32 +0000 (12:20 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 4 Jan 2018 11:20:32 +0000 (12:20 +0100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

sys-libs/openipmi/Manifest
sys-libs/openipmi/openipmi-2.0.24.ebuild [new file with mode: 0644]

index 4c535b7a9f9c660a1c08a58f67456dff927c0350..be6221359bf0e82da3feb3760fde187f3135d14f 100644 (file)
@@ -1,3 +1,4 @@
 DIST OpenIPMI-2.0.18.tar.gz 2895686 BLAKE2B 5197b58fbf3b378b296c1b3f0ddfe02f19982a2f3a08a8e6c35647f592192f1b141f1c74d9d83cba73d9f19caa03cb6a147f31b70dddce97f04860bda5579019 SHA512 a6caf791fb6d5bd83234481ea3c84a408dad3eabc093dbc4681742d23b47b223d0a1715a71a9b977a03a80f5c350dd34f6591ece5ea0d9876cb6debfc80a39d4
 DIST OpenIPMI-2.0.22.tar.gz 3081893 BLAKE2B 6ec5ec7f61f3033a9d953df4b091522fa5bd891a93dfe648f807548e3dc0f5ffc0d15af9b687379e6749d7b97ee2fd6c7f9e713aaa7423b82bf099fb2d0fb6b8 SHA512 78017fc0b52ce6a83db45f595f50170410120c9f7394429869c177ee40ea5b924bcc0e36bb60f9368a75a2f78ff71c70ae3631ba55a207cfb6eb4f62aa44ff89
 DIST OpenIPMI-2.0.23-rc1.tar.gz 3225557 BLAKE2B d67e0f0f401c174cba805cf7ce6d46a9133e5bb87f40776f91200ace3f27be023373d26ae74900dbf8c211c8d246a28105f347fd1e6f6d83ba9d92cf984ac11a SHA512 4da3d74073fe19573b8bc5fda15ecfa4d500a074559155456010e0bac8a8c2d345e30c086a851a9a4e7266165dd9a7a6d8f618e65bad3c2b18fe86d8f4c362ab
+DIST OpenIPMI-2.0.24.tar.gz 3211633 BLAKE2B 56658e0c06ae2d192415fb5d71fe13afc5819a7b2412af8f51d829a11f3ad10faf592b5da4cb51e43667303385ca2c1f8413045bc444f045d6f3e0f6dc553682 SHA512 de1e0a46d7e25af06e07a0f5b8e23deac14d2bca854fbe09b221e776b46b5cf13b5af6b7ee1e8d0984eb792aa4bd095d66d98775674809feafe0a357ca95d677
diff --git a/sys-libs/openipmi/openipmi-2.0.24.ebuild b/sys-libs/openipmi/openipmi-2.0.24.ebuild
new file mode 100644 (file)
index 0000000..caa0c82
--- /dev/null
@@ -0,0 +1,108 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils autotools python-single-r1
+
+DESCRIPTION="Library interface to IPMI"
+HOMEPAGE="https://sourceforge.net/projects/openipmi/"
+MY_PN="OpenIPMI"
+MY_P="${MY_PN}-${PV/_/-}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~x86"
+IUSE="crypt snmp perl python tcl"
+S="${WORKDIR}/${MY_P}"
+RESTRICT='test'
+
+RDEPEND="
+       dev-libs/glib:2
+       sys-libs/gdbm:=
+       sys-libs/ncurses:0=
+       crypt? ( dev-libs/openssl:0= )
+       snmp? ( net-analyzer/net-snmp )
+       perl? ( dev-lang/perl )
+       python? ( ${PYTHON_DEPS} )
+       tcl? ( dev-lang/tcl:0= )"
+DEPEND="${RDEPEND}
+       >=dev-lang/swig-1.3.21
+       virtual/pkgconfig"
+# Gui is broken!
+#              python? ( tcl? ( tk? ( dev-lang/tk dev-tcltk/tix ) ) )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+       # Bug #338499: The installed OpenIPMIpthread.pc depends on a non-existing
+       # pthread.pc. We patch it to link -lpthread directly instead.
+       "${FILESDIR}/${PN}-2.0.16-pthreads.patch"
+
+       # https://bugs.gentoo.org/501510
+       "${FILESDIR}/${PN}-2.0.21-tinfo.patch"
+)
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+
+       # Bug #290763: The buildsys tries to compile+optimize the py file during
+       # install, when the .so might not be been added yet. We just skip the files
+       # and use python_optimize ourselves later instead.
+       sed -r -i \
+               -e '/INSTALL.*\.py[oc] /d' \
+               -e '/install-exec-local/s,OpenIPMI.pyc OpenIPMI.pyo,,g' \
+               swig/python/Makefile.{am,in}
+
+       # Bug #298250: parallel install fix.
+       sed -r -i \
+               -e '/^install-data-local:/s,$, install-exec-am,g' \
+               cmdlang/Makefile.{am,in}
+
+       # We touch the .in and .am above because if we use the below, the Perl stuff
+       # is very fragile, and often fails to link.
+       #cd "${S}"
+       eautoreconf
+}
+
+src_configure() {
+       local myconf=(
+               # these binaries are for root!
+               --bindir=/usr/sbin
+               --with-glib
+               --with-glibver=2.0
+               --with-swig
+               --without-tkinter
+               $(use_with snmp ucdsnmp yes)
+               $(use_with crypt openssl yes)
+               $(use_with perl perl yes)
+               $(use_with tcl tcl yes)
+               $(use_with python python yes)
+       )
+
+       # GUI is broken
+       #use tk && use python && use !tcl && \
+       #       ewarn "Not building Tk GUI because it needs both Python AND Tcl"
+       #if use python && use tcl; then
+       #       myconf+=( $(use_with tk tkinter) )
+       #else
+       #       myconf+=( --without-tkinter )
+       #fi
+
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+       dodoc README* FAQ ChangeLog TODO doc/IPMI.pdf lanserv/README.vm
+       newdoc cmdlang/README README.cmdlang
+
+       use python && python_optimize
+}