x11-plugins/wmcliphist: fix PREFIX during src_compile (bug 556862, thanks Robert...
authorMichael Weber <xmw@gentoo.org>
Wed, 12 Aug 2015 22:14:54 +0000 (00:14 +0200)
committerMichael Weber <xmw@gentoo.org>
Wed, 12 Aug 2015 22:16:02 +0000 (00:16 +0200)
Package-Manager: portage-2.2.20.1

x11-plugins/wmcliphist/wmcliphist-2.1-r1.ebuild [new file with mode: 0644]

diff --git a/x11-plugins/wmcliphist/wmcliphist-2.1-r1.ebuild b/x11-plugins/wmcliphist/wmcliphist-2.1-r1.ebuild
new file mode 100644 (file)
index 0000000..f15d4cc
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Dockable clipboard history application for Window Maker"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmcliphist"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+S=${WORKDIR}/dockapps
+
+src_prepare() {
+       sed -e '/^PREFIX/s:=.*:=/usr:' \
+               -i Makefile || die
+       tc-export CC
+}
+
+src_install() {
+       default
+
+       dodoc ChangeLog README
+       newdoc ${PN}rc ${PN}rc.sample
+}