gnome-base/nautilus: version bump 3.22.3 → 3.24.2.1
authorGilles Dartiguelongue <eva@gentoo.org>
Fri, 11 Aug 2017 06:48:16 +0000 (08:48 +0200)
committerGilles Dartiguelongue <eva@gentoo.org>
Tue, 15 Aug 2017 22:43:08 +0000 (00:43 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

gnome-base/nautilus/Manifest
gnome-base/nautilus/nautilus-3.24.2.1.ebuild [new file with mode: 0644]
gnome-extra/gnome-color-manager/Manifest
gnome-extra/gnome-color-manager/gnome-color-manager-3.24.0.ebuild [new file with mode: 0644]

index 96dc8639bd90e9980ea65bd74f2a64dd1d7a8b91..754c433c40da942b12c6bd6b200619b3d095699f 100644 (file)
@@ -1,2 +1,3 @@
 DIST nautilus-3.20.4.tar.xz 3453376 SHA256 b15f4778950752e5d5748f198d69106be3425cdc70574be75c25f8f931a2766c SHA512 01bee5c70067c508ca918948afe0b400680eb68518ae69803e2971a215b0eaf54c9251566c6c44835a1c0b9b20248450539a47936c6aba5c9accc9ef3cbe8a8e WHIRLPOOL bf9a3549cb16c8860a470aac07b91cee349adf7ac820847afe093db160fd2f9a4c9f2c6cf7625c7f19415a6957547353662edd33358ddf0b1a86f33169812314
 DIST nautilus-3.22.3.tar.xz 5104800 SHA256 64c232f743a2bae3fce3c76d5aa65e378d11bb431fefde9013162069abff4e22 SHA512 abad02d2b36230348cec04bcc2650cc352e232008c4e628096880a93b647a0da86b43b9df6cbd621334e7292e2d00f68010783858dbfa38061ab7eafd3c4c912 WHIRLPOOL 7dde08228204b2817942071b0a5a1d31ba2d699b96ef821b4cdff301e8d26fd92a36f82b74e7acfeda4018cfa3dc082b0aac66360b0dc940706fd877755e2a48
+DIST nautilus-3.24.2.1.tar.xz 5143440 SHA256 357d9d051fcc2c385ce9b3beb2db2ea1874b7cdf507ca10274a063023e1a61b3 SHA512 f6868600bcdc82071b3a63f4e4a0f7decf0d72e021eb3d0c26e914413c858163ee4403c4f3ef7689556a0fc91394f30cff9a3db14da030b277b50972c7b80a07 WHIRLPOOL f98196cace9b0558abfbfd1bb3be05aefb7dade5edc47dfa675341c6465d4dc343e1fb0b2262c91a57cf090f82debf756d2be7000298def24151ff0aff3a1c30
diff --git a/gnome-base/nautilus/nautilus-3.24.2.1.ebuild b/gnome-base/nautilus/nautilus-3.24.2.1.ebuild
new file mode 100644 (file)
index 0000000..351af7b
--- /dev/null
@@ -0,0 +1,111 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes" # Needed with USE 'sendto'
+
+inherit gnome2 readme.gentoo-r1 virtualx
+
+DESCRIPTION="A file manager for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Nautilus"
+
+LICENSE="GPL-2+ LGPL-2+ FDL-1.1"
+SLOT="0"
+IUSE="exif gnome +introspection packagekit +previewer selinux sendto tracker xmp"
+
+KEYWORDS="~amd64 ~arm64 ~ia64 ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+
+# FIXME: tests fails under Xvfb, but pass when building manually
+# "FAIL: check failed in nautilus-file.c, line 8307"
+# need org.gnome.SessionManager service (aka gnome-session) but cannot find it
+RESTRICT="test"
+
+# Require {glib,gdbus-codegen}-2.30.0 due to GDBus API changes between 2.29.92
+# and 2.30.0
+COMMON_DEPEND="
+       >=app-arch/gnome-autoar-0.2.1
+       >=dev-libs/glib-2.51.2:2[dbus]
+       >=x11-libs/pango-1.28.3
+       >=x11-libs/gtk+-3.21.6:3[introspection?]
+       >=dev-libs/libxml2-2.7.8:2
+       >=gnome-base/gnome-desktop-3:3=
+
+       gnome-base/dconf
+       >=gnome-base/gsettings-desktop-schemas-3.8.0
+       x11-libs/libX11
+       x11-libs/libXext
+       x11-libs/libXrender
+
+       exif? ( >=media-libs/libexif-0.6.20 )
+       introspection? ( >=dev-libs/gobject-introspection-0.6.4:= )
+       selinux? ( >=sys-libs/libselinux-2 )
+       tracker? ( >=app-misc/tracker-1:= )
+       xmp? ( >=media-libs/exempi-2.1.0:2 )
+"
+DEPEND="${COMMON_DEPEND}
+       >=dev-lang/perl-5
+       >=dev-util/gdbus-codegen-2.33
+       >=dev-util/gtk-doc-am-1.10
+       >=sys-devel/gettext-0.19.7
+       virtual/pkgconfig
+       x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+       packagekit? ( app-admin/packagekit-base )
+       sendto? ( !<gnome-extra/nautilus-sendto-3.0.1 )
+"
+
+# For eautoreconf
+#      gnome-base/gnome-common
+#      dev-util/gtk-doc-am"
+
+PDEPEND="
+       gnome? ( x11-themes/adwaita-icon-theme )
+       tracker? ( >=gnome-extra/nautilus-tracker-tags-0.12 )
+       previewer? ( >=gnome-extra/sushi-0.1.9 )
+       sendto? ( >=gnome-extra/nautilus-sendto-3.0.1 )
+       >=gnome-base/gvfs-1.14[gtk]
+"
+# Need gvfs[gtk] for recent:/// support
+
+src_prepare() {
+       if use previewer; then
+               DOC_CONTENTS="nautilus uses gnome-extra/sushi to preview media files.
+                       To activate the previewer, select a file and press space; to
+                       close the previewer, press space again."
+       fi
+       gnome2_src_prepare
+}
+
+src_configure() {
+       gnome2_src_configure \
+               --enable-desktop \
+               --disable-profiling \
+               --disable-update-mimedb \
+               $(use_enable exif libexif) \
+               $(use_enable introspection) \
+               $(use_enable packagekit) \
+               $(use_enable sendto nst-extension) \
+               $(use_enable selinux) \
+               $(use_enable tracker) \
+               $(use_enable xmp)
+}
+
+src_test() {
+       virtx emake check
+}
+
+src_install() {
+       use previewer && readme.gentoo_create_doc
+       gnome2_src_install
+}
+
+pkg_postinst() {
+       gnome2_pkg_postinst
+
+       if use previewer; then
+               readme.gentoo_print_elog
+       else
+               elog "To preview media files, emerge nautilus with USE=previewer"
+       fi
+}
index d98210782a3cf862c9674e2b4d2ddb4dcea27480..f2c472dc29ba1ecc7e72c1c596fba0f3b75ffffe 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-color-manager-3.22.2.tar.xz 2671864 SHA256 e837a184e66a6a5fb778730a58d3aa8d3a10a447e13f48efc86cac7e4c94d45b SHA512 dd50cff841fc8e70554c0c998494e363b709d1a8d4084dfc8daca6297d9491c1b797c4f3f106284e0f8ef133ac77704ad805b5519566c2f49e311f30a1e8397f WHIRLPOOL 188bf45db1e7713fdf884d35ce6274a65a9d4f338a428b4555ba8d09b75d9f907b60377d8bcc355f0afe9ad93ae106f2d0eeb4a49150112f2d476883e60990dc
+DIST gnome-color-manager-3.24.0.tar.xz 2857120 SHA256 a1009e6287d97b8d1fdd6e44a4c8668bcf05f1bb7f2186243318e54c6d061dd2 SHA512 e145caf4e885ea6e9c4ee5a5b4d800d70af338e26d3bfcda81e20c6144e36d0581638d07099302d30787d6d30e9d58f2b8373f6585ae3788df825d6d24f5b003 WHIRLPOOL 9882c9610a93fe5eb82f8ba66a559b7675cf4902ba5129b94dc3ad19f6c7d37aaabe8cb753957959587f04d6f0d89c7598a46cd30274c27c7ead331873917215
diff --git a/gnome-extra/gnome-color-manager/gnome-color-manager-3.24.0.ebuild b/gnome-extra/gnome-color-manager/gnome-color-manager-3.24.0.ebuild
new file mode 100644 (file)
index 0000000..55f0c58
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 virtualx
+
+DESCRIPTION="Color profile manager for the GNOME desktop"
+HOMEPAGE="https://git.gnome.org/browse/gnome-color-manager"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="packagekit raw"
+
+# Need gtk+-3.3.8 for https://bugzilla.gnome.org/show_bug.cgi?id=673331
+RDEPEND="
+       >=dev-libs/glib-2.31.10:2
+       >=media-libs/lcms-2.2:2
+       >=media-libs/libcanberra-0.10[gtk3]
+       media-libs/libexif
+       media-libs/tiff:0=
+
+       >=x11-libs/gtk+-3.3.8:3
+       >=x11-libs/vte-0.25.1:2.91
+       >=x11-misc/colord-1.3.1:0=
+       >=x11-libs/colord-gtk-0.1.20
+
+       packagekit? ( app-admin/packagekit-base )
+       raw? ( media-gfx/exiv2 )
+"
+# docbook-sgml-{utils,dtd:4.1} needed to generate man pages
+DEPEND="${RDEPEND}
+       app-text/docbook-sgml-dtd:4.1
+       app-text/docbook-sgml-utils
+       dev-libs/appstream-glib
+       dev-libs/libxslt
+       dev-util/itstool
+       >=sys-devel/gettext-0.19.7
+       virtual/pkgconfig
+"
+
+src_configure() {
+       # Always enable tests since they are check_PROGRAMS anyway
+       # appstream does not want to be relax by default !
+       gnome2_src_configure \
+               --disable-static \
+               --enable-tests \
+               $(use_enable packagekit) \
+               $(use_enable raw exiv)
+#              APPSTREAM_UTIL=$(type -P true)
+}
+
+src_test() {
+       virtx emake check
+}
+
+pkg_postinst() {
+       gnome2_pkg_postinst
+
+       if ! has_version media-gfx/argyllcms ; then
+               elog "If you want to do display or scanner calibration, you will need to"
+               elog "install media-gfx/argyllcms"
+       fi
+}