media-gfx/iscan: fix building with gcc 10
authorMarcin Deranek <marcin.deranek@booking.com>
Fri, 8 May 2020 21:49:21 +0000 (23:49 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 10 May 2020 11:31:19 +0000 (13:31 +0200)
Closes: https://bugs.gentoo.org/721812
Signed-off-by: Marcin Deranek <marcin.deranek@slonko.net>
Closes: https://github.com/gentoo/gentoo/pull/15718
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-gfx/iscan/files/iscan-3.62.0-gcc-10.patch [new file with mode: 0644]
media-gfx/iscan/iscan-3.62.0.ebuild

diff --git a/media-gfx/iscan/files/iscan-3.62.0-gcc-10.patch b/media-gfx/iscan/files/iscan-3.62.0-gcc-10.patch
new file mode 100644 (file)
index 0000000..4f8c63c
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/utsushi/string.hpp       2020-05-08 23:20:11.642359134 +0200
++++ b/utsushi/string.hpp       2020-05-08 23:20:21.834246187 +0200
+@@ -23,6 +23,7 @@
+ #include <iosfwd>
+ #include <string>
++#include <iostream>
+ #include <boost/operators.hpp>
+--- a/utsushi/toggle.hpp       2019-11-18 03:08:06.000000000 +0100
++++ b/utsushi/toggle.hpp       2020-05-08 23:23:40.284045167 +0200
+@@ -22,6 +22,7 @@
+ #define utsushi_toggle_hpp_
+ #include <iosfwd>
++#include <iostream>
+ #include <boost/operators.hpp>
+ namespace utsushi {
index 2a2c97d15125f37241d7523344d8c6d74ef52f4e..f5957958df9abea68ac8f7af5850a5656f22e8d1 100644 (file)
@@ -32,6 +32,7 @@ S="${WORKDIR}/utsushi-0.$(ver_cut 2-3)"
 PATCHES=(
        "${FILESDIR}"/${PN}-3.61.0-ijg-libjpeg.patch
        "${FILESDIR}"/${PN}-3.61.0-imagemagick-7.patch
+       "${FILESDIR}"/${PN}-3.62.0-gcc-10.patch
 )
 
 src_prepare() {