dev-python/pyopenssl: Remove old
authorMichał Górny <mgorny@gentoo.org>
Wed, 22 Apr 2020 06:14:24 +0000 (08:14 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 22 Apr 2020 08:15:27 +0000 (10:15 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyopenssl/Manifest
dev-python/pyopenssl/pyopenssl-19.0.0.ebuild [deleted file]

index 7b91c85c05e3b4788548d5c498fe6a869ee7d524..ea84bd5c37d15a172e7dc6df3dac2c8c86b3d195 100644 (file)
@@ -1,2 +1 @@
-DIST pyOpenSSL-19.0.0.tar.gz 168551 BLAKE2B 762d3358b3cc4f1e088e9464ac079e5212c537d25691e51edb3255a192c42276506c758ecf16eff999082bfd05aeb92a37741338d92036d2149b87c95008db05 SHA512 a7e12bf5be725ccebd1223d567a9b9e8bd35f79cbf3a0409108fa6f00e10ab137dd6876369e9dede02b2abc7d700786cc905532ca5c31b6e246f6df8b24e2818
 DIST pyOpenSSL-19.1.0.tar.gz 160510 BLAKE2B e6e39f860221a2696aa3fa32ac89ed48e34b18e4accc366a86264d943a15a1b00ba1a0d8349550d1775d25836aa5d214e1e3fe4ec0a9c0f6d5ab00cd9fede633 SHA512 4acd96f287d72eb11bd812697d28cd6eb6a96a4653248b65f967187830a6b17cc1254775a18a3405469f3d45abdae6f02d165f2f35f035f3174c2826fba82916
diff --git a/dev-python/pyopenssl/pyopenssl-19.0.0.ebuild b/dev-python/pyopenssl/pyopenssl-19.0.0.ebuild
deleted file mode 100644 (file)
index 5e164eb..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-MY_PN=pyOpenSSL
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python interface to the OpenSSL library"
-HOMEPAGE="
-       http://pyopenssl.sourceforge.net/
-       https://launchpad.net/pyopenssl
-       https://pypi.org/project/pyOpenSSL/
-"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
-       >=dev-python/cryptography-2.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       doc? (
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
-       )
-       test? (
-               virtual/python-cffi[${PYTHON_USEDEP}]
-               dev-python/flaky[${PYTHON_USEDEP}]
-               dev-python/pretend[${PYTHON_USEDEP}]
-               >=dev-python/pytest-3.0.1[${PYTHON_USEDEP}]
-       )"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
-       # Requires network access
-       sed -i -e 's/test_set_default_verify_paths/_&/' tests/test_ssl.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C doc html
-}
-
-python_test() {
-       TZ=UTC py.test -v || die "Testing failed with ${EPYTHON}" # Fixes bug #627530
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/_build/html/. )
-       if use examples ; then
-               docinto examples
-               dodoc -r examples/*
-               docompress -x /usr/share/doc/${PF}/examples
-       fi
-
-       distutils-r1_python_install_all
-}