dev-python/mygpoclient: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sun, 11 Nov 2018 16:22:13 +0000 (17:22 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 11 Nov 2018 16:31:04 +0000 (17:31 +0100)
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-python/mygpoclient/Manifest
dev-python/mygpoclient/mygpoclient-1.8.ebuild [new file with mode: 0644]

index 99063cbe2d0c4ef8eae77e52eada27b8b6b45f8b..06c908eee9abe3339d664e1e04c466e4f8a5d4b4 100644 (file)
@@ -1 +1,2 @@
 DIST mygpoclient-1.7.tar.gz 36423 BLAKE2B 6331eff9d095a705cb805a8984f530b418d8f8f61dcb239fd3dba4236c8f376dcb329747887c4f22f66ca657525c3333ea260d5e2d2093a37d33dea43d2ca93d SHA512 618c94cea37f427fbef333a7cecade12fadda33bd727814b4ce904e74aae65d4ba85d7d09578b9e5b6b9fb0b2f6fe0f73abbd7f60d66b3d9b51dabb554169e9f
+DIST mygpoclient-1.8.tar.gz 43671 BLAKE2B 0a1c10c00a9ee034acc17bb5e28d1ebab50a14f3eea534f4a4277172251ce567a26e7ab66859a66d89d4adc06f44dfe5899edb0aeec45e90e461a4a8cb3ff337 SHA512 1edecd5ccb116c7f4017ebe6572439d87ff76501ed0628934e548dc0c9c041127a11ec9f4def4a54a6f7fabe46a461c863ec2ff2f8c14c3c67b5d1fd9285bb9f
diff --git a/dev-python/mygpoclient/mygpoclient-1.8.ebuild b/dev-python/mygpoclient/mygpoclient-1.8.ebuild
new file mode 100644 (file)
index 0000000..bb56a43
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{6,7}} pypy )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A gpodder.net client library"
+HOMEPAGE="https://github.com/gpodder/mygpoclient
+       https://mygpoclient.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/gpodder/mygpoclient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       test? (
+               dev-python/coverage[${PYTHON_USEDEP}]
+               dev-python/minimock
+       )
+"
+
+PATCHES=( "${FILESDIR}"/tests.patch )
+
+src_prepare() {
+       distutils-r1_src_prepare
+       # Disable tests requring network connection.
+       rm -f mygpoclient/http_test.py
+}
+
+python_test() {
+       if [[ "${EPYTHON:0:4}" == "pypy" ]]; then
+               nosetests --cover-erase --with-coverage --cover-package=mygpoclient "${BUILD_DIR}"/lib/${PN}/
+       else
+               nosetests --cover-erase --with-coverage --with-doctest --cover-package=mygpoclient "${BUILD_DIR}"/lib/${PN}/
+       fi
+}
+
+src_install() {
+       distutils-r1_src_install
+       rm -f $(find "${D}" -name "*_test.py")
+}