media-sound/scmpc: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 16:02:38 +0000 (17:02 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 16:02:38 +0000 (17:02 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-sound/scmpc/scmpc-0.4.1.ebuild

index 714a7b51ba2a0b95f3160855bbf869cfcce6a3c4..7eee1b1aa5be5ea7f1cd6b11e8388f9eda0257d3 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
 DESCRIPTION="a client for MPD which submits your tracks to last.fm"
 HOMEPAGE="https://cmende.github.com/scmpc/"
@@ -10,19 +10,18 @@ SRC_URI="https://dev.gentoo.org/~angelos/${P}.tar.bz2"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 x86"
-IUSE=""
 
-RDEPEND="dev-libs/glib:2
-       dev-libs/confuse
-       media-libs/libmpdclient
-       net-misc/curl"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
-
-DOCS=( AUTHORS ChangeLog NEWS README.md scmpc.conf.example )
+RDEPEND="
+       dev-libs/glib:2
+       dev-libs/confuse:=
+       media-libs/libmpdclient:=
+       net-misc/curl:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
 
 src_install() {
        default
+       dodoc scmpc.conf.example
 
        newinitd "${FILESDIR}"/${PN}-2.init ${PN}
        insinto /etc