Version bump, remove old testing-only version.
authorHans de Graaff <graaff@gentoo.org>
Sun, 21 Jan 2007 20:52:04 +0000 (20:52 +0000)
committerHans de Graaff <graaff@gentoo.org>
Sun, 21 Jan 2007 20:52:04 +0000 (20:52 +0000)
Package-Manager: portage-2.1.1-r2

dev-ruby/rmagick/ChangeLog
dev-ruby/rmagick/files/digest-rmagick-1.15.0 [new file with mode: 0644]
dev-ruby/rmagick/rmagick-1.15.0.ebuild [new file with mode: 0644]

index 50abf6794c1721283a21c903c6374bf2e3bbd7a4..af869aa7eb84abf4c7dc8bb52ccce62c823881cc 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-ruby/rmagick
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.36 2007/01/21 10:14:14 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.37 2007/01/21 20:52:04 graaff Exp $
+
+*rmagick-1.15.0 (21 Jan 2007)
+
+  21 Jan 2007; Hans de Graaff <graaff@gentoo.org> -rmagick-1.10.1.ebuild,
+  +rmagick-1.15.0.ebuild:
+  Version bump with several bug fixes. Remove testing-only 1.10.1 version.
 
   21 Jan 2007; Christian Faulhammer <opfer@gentoo.org>
   rmagick-1.14.1-r1.ebuild:
diff --git a/dev-ruby/rmagick/files/digest-rmagick-1.15.0 b/dev-ruby/rmagick/files/digest-rmagick-1.15.0
new file mode 100644 (file)
index 0000000..c9a5fcb
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 1dad706e1bbe6c7bcd3a3024bb03663c RMagick-1.15.0.tar.bz2 955390
+RMD160 e6d65e70fc02589f27d0b5926632d82fe442dcdb RMagick-1.15.0.tar.bz2 955390
+SHA256 6126905c0e24beef7057eaf33ddc322976f6e78fc145f18c16970553d90d6658 RMagick-1.15.0.tar.bz2 955390
diff --git a/dev-ruby/rmagick/rmagick-1.15.0.ebuild b/dev-ruby/rmagick/rmagick-1.15.0.ebuild
new file mode 100644 (file)
index 0000000..3123b0f
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-1.15.0.ebuild,v 1.1 2007/01/21 20:52:04 graaff Exp $
+
+RUBY_BUG_145222=yes
+inherit ruby
+
+# The gem for this package doesn't seem to play well with portage.  It
+# runs a GNUish configure script, with argument passed directly from
+# the gem install command, but gem install doesn't use the same style
+# of arguments.  Thus, unless you're smart enough to come up with a
+# fix, please leave this as a source package install.
+
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/16683/RMagick-${PV}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="examples doc"
+DEPEND="virtual/ruby
+       >=media-gfx/imagemagick-6.0"
+
+S=${WORKDIR}/RMagick-${PV}
+
+# Using a custom src_compile instead of the ruby one because the ruby
+# one gets confused by an additional setup.rb that should not be used
+# here.
+src_compile() {
+       myconf="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+       # When documentation is built many examples are also run. Not all
+       # of them may work (e.g. due to missing additional dependencies)
+       # so we allow the examples to fail.
+       if ! use doc ; then
+               myconf="${myconf} --disable-htmldoc --enable-allow-example-errors"
+       fi
+
+       ./configure \
+               --prefix=/usr \
+               --host=${CHOST} \
+               --mandir=/usr/share/man \
+               --infodir=/usr/share/info \
+               --datadir=/usr/share \
+               --sysconfdir=/etc \
+               --localstatedir=/var/lib \
+               --with-ruby=${RUBY} \
+               ${myconf} \
+               "$@" || die "econf failed"
+
+       ruby_emake "$@" || die
+}
+
+# Use a custom src_install instead of the default one in ruby.eclass
+# because the one in ruby.eclass does not include setting the prefix
+# for the installation step.
+src_install() {
+       RUBY_ECONF="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+       ${RUBY} setup.rb config --prefix=${D}/usr "$@" \
+               ${RUBY_ECONF} || die "setup.rb config failed"
+       ${RUBY} setup.rb install --prefix=${D} "$@" \
+               ${RUBY_ECONF} || die "setup.rb install failed"
+}