app-arch/tardelta: update PYTHON_COMPAT
authorZac Medico <zmedico@gentoo.org>
Sun, 19 Apr 2020 18:42:36 +0000 (11:42 -0700)
committerZac Medico <zmedico@gentoo.org>
Sun, 19 Apr 2020 18:57:52 +0000 (11:57 -0700)
Closes: https://bugs.gentoo.org/718190
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Zac Medico <zmedico@gentoo.org>
app-arch/tardelta/tardelta-1.0.1.ebuild

index f1758c33e3b6e5a0f1080d3a4dd3058b6d27a450..d847ff417e0b29cb9d4858198418a6f8eeed817e 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
-
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
 inherit distutils-r1
 
 DESCRIPTION="Generate a tarball of differences between two tarballs"
@@ -14,7 +14,6 @@ LICENSE="Apache-2.0"
 KEYWORDS="~amd64 ~x86"
 SLOT="0"
 IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 
 src_prepare() {
        sed -i "s:^\(__version__ =\).*:\\1 \"${PV}\":" src/${PN}.py || die