add CATEGORY to ebuild.5 and declare it readonly in ebuild.sh
authorZac Medico <zmedico@gentoo.org>
Sun, 5 Feb 2006 21:19:11 +0000 (21:19 -0000)
committerZac Medico <zmedico@gentoo.org>
Sun, 5 Feb 2006 21:19:11 +0000 (21:19 -0000)
svn path=/main/trunk/; revision=2670

bin/ebuild.sh
man/ebuild.5

index ccd02cdb25b6e4bacd0dce995191708a545fc608..cfff8629bb92c0f337a8aae5e02925e0bcb1a734 100755 (executable)
@@ -1797,7 +1797,7 @@ export S=${WORKDIR}/${P}
 
 unset E_IUSE E_DEPEND E_RDEPEND E_PDEPEND
 
-for x in T P PN PV PVR PR A EBUILD EMERGE_FROM O PPID FILESDIR PORTAGE_TMPDIR; do
+for x in T P PN PV PVR PR CATEGORY A EBUILD EMERGE_FROM O PPID FILESDIR PORTAGE_TMPDIR; do
        [[ ${!x-UNSET_VAR} != UNSET_VAR ]] && declare -r ${x}
 done
 # Need to be able to change D in dyn_preinst due to the IMAGE stuff
index fe66914bd5ebeff7bacbb9e03a99e5621e088975..af8443df1850f2abd86aa6db54cb9254469afec8 100644 (file)
@@ -87,6 +87,9 @@ Contains the full package name \fI[PN]\-[PVR]\fR
 .br
 \fBxfree-4.2.1-r2.ebuild\fR --> \fB$PF\fR=='\fIxfree-4.2.1-r2\fR'
 .TP
+.B CATEGORY
+Contains the package category name.
+.TP
 .B A
 Contains all source files required for the package.  This variable must
 not be defined. It is autogenerated from the \fISRC_URI\fR variables.