dev-lisp/cl-ppcre: Updates EAPI
authorChema Alonso Josa <nimiux@gentoo.org>
Wed, 5 Apr 2017 17:50:34 +0000 (19:50 +0200)
committerChema Alonso Josa <nimiux@gentoo.org>
Wed, 5 Apr 2017 17:51:07 +0000 (19:51 +0200)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-lisp/cl-ppcre/cl-ppcre-2.0.11.ebuild
dev-lisp/cl-ppcre/metadata.xml

index 7aa2d5026a043b5c1d49547aa0571118a2fa86c1..ba65b3febed66220974054e83a802f3c760fb12d 100644 (file)
@@ -1,16 +1,14 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 
 inherit common-lisp-3
 
-MY_P="v${PV}"
-
 DESCRIPTION="CL-PPCRE is a portable regular expression library for Common Lisp."
 HOMEPAGE="http://weitz.de/cl-ppcre/
                  http://www.cliki.net/cl-ppcre"
-SRC_URI="https://github.com/edicl/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/edicl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="BSD-2"
 SLOT="0"
@@ -28,6 +26,5 @@ src_unpack() {
 src_install() {
        common-lisp-install-sources *.lisp test/
        common-lisp-install-asdf ${PN}
-       dodoc CHANGELOG
-       dohtml doc/index.html
+       dodoc CHANGELOG doc/index.html
 }
index c2fc0d6e9b31b01731300ffdfdf13bc12a2dc9c1..80cabfa1315042cbb1ef79a3b31beee8381e8d15 100644 (file)
@@ -5,16 +5,27 @@
                <email>common-lisp@gentoo.org</email>
                <name>Gentoo Common Lisp Project</name>
        </maintainer>
-       <longdescription>
-CL-PPCRE is a portable regular expression library for Common Lisp
-which has the following features: 
- * compatible with Perl
- * fast (outperforms Perl) 
- * portable (ANSI Common Lisp)
- * thread-safe 
- * includes convenience features
- * well-documented.
+       <longdescription lang="en">
+    CL-PPCRE is a portable regular expression library for Common Lisp
+    which has the following features:
+
+    * compatible with Perl
+    * fast (outperforms Perl)
+    * portable (ANSI Common Lisp)
+    * thread-safe
+    * includes convenience features
+    * well-documented
+       </longdescription>
+       <longdescription lang="es">
+    CL-PPCRE es una biblioteca de expressiones regulares portable
+    para Common Lisp que tiene las siguientes características:
+
+    * Compatible con Perl
+    * Rápida (más rápida que la versión para Perl)
+    * Portable (ANSI Common Lisp)
+    * Segura en la ejecución de hilos (thread-safe)
+    * Incluye características para hacerla cómoda
+    * Bien documentada
        </longdescription>
        <upstream>
                <remote-id type="github">edicl/cl-ppcre</remote-id>