media-libs/assimp: Disable pointless test
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 25 Aug 2018 23:59:37 +0000 (01:59 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 26 Aug 2018 00:00:38 +0000 (02:00 +0200)
Closes: https://bugs.gentoo.org/659122
Package-Manager: Portage-2.3.48, Repoman-2.3.10

media-libs/assimp/assimp-4.0.1.ebuild
media-libs/assimp/files/assimp-4.0.1-disabletest.patch [new file with mode: 0644]

index c3bb59596e50d4a2c5774558c948add87602eafc..8bd32676885e7db6621266c0913e80660d205837 100644 (file)
@@ -38,6 +38,7 @@ DEPEND="${RDEPEND}
 PATCHES=(
        "${FILESDIR}/findassimp-3.3.1.patch"
        "${FILESDIR}/${P}-qt-5.11.0.patch"
+       "${FILESDIR}/${P}-disabletest.patch" # bug 659122
 )
 
 src_configure() {
diff --git a/media-libs/assimp/files/assimp-4.0.1-disabletest.patch b/media-libs/assimp/files/assimp-4.0.1-disabletest.patch
new file mode 100644 (file)
index 0000000..4afe5bb
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/test/unit/utVersion.cpp  2017-07-28 22:33:41.000000000 +0200
++++ b/test/unit/utVersion.cpp  2018-08-26 01:48:54.935116440 +0200
+@@ -65,7 +65,3 @@
+     EXPECT_NE( aiGetCompileFlags(), 0U );
+ }
+-TEST_F( utVersion, aiGetVersionRevisionTest ) {
+-    EXPECT_NE( aiGetVersionRevision(), 0U );
+-}
+-