dev-python/minidb: bump to 2.0.3, Python 3.8 support
authorLouis Sautier <sbraz@gentoo.org>
Mon, 23 Mar 2020 21:56:37 +0000 (22:56 +0100)
committerLouis Sautier <sbraz@gentoo.org>
Mon, 23 Mar 2020 21:56:37 +0000 (22:56 +0100)
Also rely on more modern distutils-r1 features.

Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
dev-python/minidb/Manifest
dev-python/minidb/minidb-2.0.3.ebuild [new file with mode: 0644]

index 3aaa30e22c9888e2ad9fff6de86193aa904e425d..d200f641992d8cfcb0c2fc533e53565dfffcf0fa 100644 (file)
@@ -1 +1,2 @@
 DIST minidb-2.0.2.tar.gz 13928 BLAKE2B 7b6997bd0ed852561c1a45e1d8f63030798c59ebbe67ba3e9f38c08eddcf22028756b17c5ce8aa460e5d3113ef54cdafe782cb471aabfe208b093af702694cb7 SHA512 92879d6df61b0f9f72f9fe8f1cf38d559477983c6bba8c88ed02289570daff02f6f8d7010c0a95ffce049ab67be69323c47caefdfe3a8b008038377235ed9a5f
+DIST minidb-2.0.3.tar.gz 13992 BLAKE2B 7ccb26625c199517ee63e99b1839037046c29a4c72a26f457ef3b4c22ef1f23b0bf632b37790c2981fd2c08929a39e8f015b4cf890d04d5e9926cd07b5def699 SHA512 90e2c51af64a373a9dce5e6fad94440a8e5ff3136ba4004deebb5f9a7a7f039ebf1b903a361d678771b6e18e951cacbd7392f1fe2df8db04cef04526a07a3ce2
diff --git a/dev-python/minidb/minidb-2.0.3.ebuild b/dev-python/minidb/minidb-2.0.3.ebuild
new file mode 100644 (file)
index 0000000..06868ee
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Simple SQLite-based object store"
+HOMEPAGE="https://thp.io/2010/minidb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests nose