www-client/firefox: enable --enable-rust-simd
authorThomas Deutschmann <whissi@gentoo.org>
Tue, 29 Jan 2019 08:14:16 +0000 (09:14 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Tue, 29 Jan 2019 08:14:31 +0000 (09:14 +0100)
Closes: https://bugs.gentoo.org/676696
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
www-client/firefox/firefox-65.0.ebuild

index 3fe4b27355a0d32ef98e8289463428855b553f20..c8e59db836c42f987041a02f612763db0617c75a 100644 (file)
@@ -405,6 +405,10 @@ src_configure() {
                mozconfig_annotate '' --with-system-libevent="${SYSROOT}${EPREFIX}"/usr
        fi
 
+       if ! use x86 && [[ ${CHOST} != armv*h* ]] ; then
+               mozconfig_annotate '' --enable-rust-simd
+       fi
+
        # skia has no support for big-endian platforms
        if [[ $(tc-endian) == "big" ]] ; then
                mozconfig_annotate 'big endian target' --disable-skia
@@ -485,7 +489,6 @@ src_compile() {
 
                addpredict /root
                addpredict /etc/gconf
-               set -x
        fi
 
        MOZ_MAKE_FLAGS="${MAKEOPTS} -O" SHELL="${SHELL:-${EPREFIX}/bin/bash}" MOZ_NOSPAM=1 ${_virtx} \