dev-python/scripttest: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 09:48:48 +0000 (11:48 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 10:35:32 +0000 (12:35 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/scripttest/scripttest-1.3.0.ebuild

index 088fd5b4c2cf9e66f488454b7e04b44f3707caca..ced51f75881f9eb8acaacb5b81c1038a35c3a46a 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
 
 inherit distutils-r1
 
@@ -16,6 +16,4 @@ LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
 
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
 distutils_enable_tests pytest