app-emulation/docker: remove old versions
authorWilliam Hubbs <williamh@gentoo.org>
Mon, 23 Jan 2017 14:02:25 +0000 (08:02 -0600)
committerWilliam Hubbs <williamh@gentoo.org>
Mon, 23 Jan 2017 14:02:48 +0000 (08:02 -0600)
Package-Manager: Portage-2.3.0, Repoman-2.3.1

app-emulation/docker/Manifest
app-emulation/docker/docker-1.11.0.ebuild [deleted file]
app-emulation/docker/docker-1.13.0_rc7.ebuild [deleted file]
app-emulation/docker/files/docker-containerd.patch [deleted file]

index efd93a0fcde71d8bd8edda445fa203a8c850b9c0..f54cf9cfae1374986f950a1dcee54f643a78c2b5 100644 (file)
@@ -1,4 +1,2 @@
-DIST docker-1.11.0.tar.gz 10637394 SHA256 088869b9a19ae17656e068aa6d3d473866e8133365427c601c671da1b2189057 SHA512 ecb7f531a5632fd6274e3eec59a5194c61d0788ab9f3864845cbc248232c2f14671a26c34abab8c5ca85ce6106ae72ea3ae4e5d133ad1efb126069ae82a2dba0 WHIRLPOOL 20b0ef1642d2fea2ae186a17786d95f138fb7df92daa104f00c481488f82eadd5e8f27a0a8e926d68f495fd62bc132d83817a0831f84b3786474a9408d87878f
 DIST docker-1.12.6.tar.gz 13694205 SHA256 0413f3513c2a6842ed9cf837154c8a722e9b34cb36b33430348489baa183707e SHA512 98e0fa0ec0dad4d392188b0d2cf42b2b564403463c369e1fe060f1abc2e97d97375a88587080671ef905e6a34b991d83265f43c3112575af019cf85eef0c2c25 WHIRLPOOL 55d10e4c4ab960320094637a847768ad85dc1fccaa6cc77ea0ca82f2d23b27e92e2f2c0cbc03f53676012c95883f65c6fa16d26970138fa129d37bf278fc8c0b
 DIST docker-1.13.0.tar.gz 7746065 SHA256 845cc9a7a48ed1cc60f062882285358a1c2a845b74c5d1d859606a28e4a47d3e SHA512 c5531f0c4bfeb541a4bf9b324830afaa27edb99f34990bdfa588843baa169edb1c2d545452ee8074a1ac322e7788952eb369db884c015e29763247e1e023172c WHIRLPOOL 87fcadde4ef2c15d432b38e06c4ed4d6df03bb6ecddd24e489712020c2be3932da2f9ff47c2fc78dd0b56dacb94b89dc58a2d1c7d8995e1e5b834acd28a33011
-DIST docker-1.13.0_rc7.tar.gz 7745191 SHA256 fe87ec128309c9cd212690844d799ceb83a0ef25fca0a6b4a0c4f58c60f79391 SHA512 4f574bee7d0ef2d734843418f7e13e7ba83cc22b2b98261771fbfd40854a0a7efaf3eeb152662d00d21aaba7b6fe7d7e5de051ba7fd6919da8d28a7470023f3b WHIRLPOOL 10252222d7e7c598c808c7b01f3d658fab379462ff3c5a6cdb70d2b2dd9a73c052f436be170ffe74e73b21bf49e761205102ac049b0f0363aaa29d81991d2721
diff --git a/app-emulation/docker/docker-1.11.0.ebuild b/app-emulation/docker/docker-1.11.0.ebuild
deleted file mode 100644 (file)
index 43b5a38..0000000
+++ /dev/null
@@ -1,275 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-EGO_PN="github.com/docker/docker"
-
-if [[ ${PV} = *9999* ]]; then
-       # Docker cannot be fetched via "go get", thanks to autogenerated code
-       EGIT_REPO_URI="https://${EGO_PN}.git"
-       EGIT_CHECKOUT_DIR="${WORKDIR}/${P}/src/${EGO_PN}"
-       inherit golang-base git-r3
-else
-       MY_PV="${PV/_/-}"
-       DOCKER_GITCOMMIT="4dc5990"
-       EGIT_COMMIT="v${MY_PV}"
-       SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="amd64"
-       [ "$DOCKER_GITCOMMIT" ] || die "DOCKER_GITCOMMIT must be added manually for each bump!"
-       inherit golang-vcs-snapshot
-fi
-inherit bash-completion-r1 linux-info multilib systemd udev user
-
-DESCRIPTION="The core functions you need to create Docker images and run Docker containers"
-HOMEPAGE="https://dockerproject.org"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="apparmor aufs btrfs +device-mapper experimental overlay seccomp"
-
-# https://github.com/docker/docker/blob/master/hack/PACKAGERS.md#build-dependencies
-CDEPEND="
-       >=dev-db/sqlite-3.7.9:3
-       device-mapper? (
-               >=sys-fs/lvm2-2.02.89[thin]
-       )
-       seccomp? (
-               >=sys-libs/libseccomp-2.2.1[static-libs]
-       )
-"
-
-DEPEND="
-       ${CDEPEND}
-
-       dev-go/go-md2man
-
-       btrfs? (
-               >=sys-fs/btrfs-progs-3.8
-       )
-"
-
-# https://github.com/docker/docker/blob/master/hack/PACKAGERS.md#runtime-dependencies
-# https://github.com/docker/docker/blob/master/hack/PACKAGERS.md#optional-dependencies
-RDEPEND="
-       ${CDEPEND}
-
-       !app-emulation/docker-bin
-       >=net-firewall/iptables-1.4
-       sys-process/procps
-       >=dev-vcs/git-1.7
-       >=app-arch/xz-utils-4.9
-
-       >=app-emulation/containerd-0.2.0
-       >=app-emulation/runc-0.1.0
-
-       apparmor? (
-               sys-libs/libapparmor[static-libs]
-       )
-"
-
-RESTRICT="installsources strip"
-
-# see "contrib/check-config.sh" from upstream's sources
-CONFIG_CHECK="
-       ~NAMESPACES ~NET_NS ~PID_NS ~IPC_NS ~UTS_NS
-       ~DEVPTS_MULTIPLE_INSTANCES
-       ~CGROUPS ~CGROUP_CPUACCT ~CGROUP_DEVICE ~CGROUP_FREEZER ~CGROUP_SCHED ~CPUSETS ~MEMCG
-       ~KEYS ~MACVLAN ~VETH ~BRIDGE ~BRIDGE_NETFILTER
-       ~NF_NAT_IPV4 ~IP_NF_FILTER ~IP_NF_TARGET_MASQUERADE
-       ~NETFILTER_XT_MATCH_ADDRTYPE ~NETFILTER_XT_MATCH_CONNTRACK
-       ~NF_NAT ~NF_NAT_NEEDED
-
-       ~POSIX_MQUEUE
-
-       ~MEMCG_KMEM ~MEMCG_SWAP ~MEMCG_SWAP_ENABLED
-
-       ~BLK_CGROUP ~IOSCHED_CFQ
-       ~CGROUP_PERF
-       ~CGROUP_HUGETLB
-       ~NET_CLS_CGROUP
-       ~CFS_BANDWIDTH ~FAIR_GROUP_SCHED ~RT_GROUP_SCHED
-"
-
-ERROR_KEYS="CONFIG_KEYS: is mandatory, see bug 581348"
-ERROR_MEMCG_KMEM="CONFIG_MEMCG_KMEM: is optional"
-ERROR_MEMCG_SWAP="CONFIG_MEMCG_SWAP: is required if you wish to limit swap usage of containers"
-ERROR_RESOURCE_COUNTERS="CONFIG_RESOURCE_COUNTERS: is optional for container statistics gathering"
-
-ERROR_BLK_CGROUP="CONFIG_BLK_CGROUP: is optional for container statistics gathering"
-ERROR_IOSCHED_CFQ="CONFIG_IOSCHED_CFQ: is optional for container statistics gathering"
-ERROR_CGROUP_PERF="CONFIG_CGROUP_PERF: is optional for container statistics gathering"
-ERROR_CFS_BANDWIDTH="CONFIG_CFS_BANDWIDTH: is optional for container statistics gathering"
-
-pkg_setup() {
-       if kernel_is lt 3 10; then
-               ewarn ""
-               ewarn "Using Docker with kernels older than 3.10 is unstable and unsupported."
-               ewarn " - http://docs.docker.com/installation/binaries/#check-kernel-dependencies"
-       fi
-
-       # for where these kernel versions come from, see:
-       # https://www.google.com/search?q=945b2b2d259d1a4364a2799e80e8ff32f8c6ee6f+site%3Akernel.org%2Fpub%2Flinux%2Fkernel+file%3AChangeLog*
-       if ! {
-               kernel_is ge 3 16 \
-               || { kernel_is 3 15 && kernel_is ge 3 15 5; } \
-               || { kernel_is 3 14 && kernel_is ge 3 14 12; } \
-               || { kernel_is 3 12 && kernel_is ge 3 12 25; }
-       }; then
-               ewarn ""
-               ewarn "There is a serious Docker-related kernel panic that has been fixed in 3.16+"
-               ewarn "  (and was backported to 3.15.5+, 3.14.12+, and 3.12.25+)"
-               ewarn ""
-               ewarn "See also https://github.com/docker/docker/issues/2960"
-       fi
-
-       if kernel_is le 3 18; then
-               CONFIG_CHECK+="
-                       ~RESOURCE_COUNTERS
-               "
-       fi
-
-       if kernel_is le 3 13; then
-               CONFIG_CHECK+="
-                       ~NETPRIO_CGROUP
-               "
-       else
-               CONFIG_CHECK+="
-                       ~CGROUP_NET_PRIO
-               "
-       fi
-
-       if use aufs; then
-               CONFIG_CHECK+="
-                       ~AUFS_FS
-                       ~EXT4_FS_POSIX_ACL ~EXT4_FS_SECURITY
-               "
-               ERROR_AUFS_FS="CONFIG_AUFS_FS: is required to be set if and only if aufs-sources are used instead of aufs4/aufs3"
-       fi
-
-       if use btrfs; then
-               CONFIG_CHECK+="
-                       ~BTRFS_FS
-               "
-       fi
-
-       if use device-mapper; then
-               CONFIG_CHECK+="
-                       ~BLK_DEV_DM ~DM_THIN_PROVISIONING ~EXT4_FS ~EXT4_FS_POSIX_ACL ~EXT4_FS_SECURITY
-               "
-       fi
-
-       if use overlay; then
-               CONFIG_CHECK+="
-                       ~OVERLAY_FS ~EXT4_FS_SECURITY ~EXT4_FS_POSIX_ACL
-               "
-       fi
-
-       linux-info_pkg_setup
-
-       # create docker group for the code checking for it in /etc/group
-       enewgroup docker
-}
-
-src_prepare() {
-       cd "src/${EGO_PN}" || die
-       epatch "${FILESDIR}/docker-containerd.patch"
-       # allow user patches (use sparingly - upstream won't support them)
-       epatch_user
-}
-
-src_compile() {
-       cd "src/${EGO_PN}" || die
-       export GOPATH="${WORKDIR}/${P}:${PWD}/vendor"
-
-       # setup CFLAGS and LDFLAGS for separate build target
-       # see https://github.com/tianon/docker-overlay/pull/10
-       export CGO_CFLAGS="-I${ROOT}/usr/include"
-       export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
-
-       # if we're building from a zip, we need the GITCOMMIT value
-       [ "$DOCKER_GITCOMMIT" ] && export DOCKER_GITCOMMIT
-
-       if gcc-specs-pie; then
-               sed -i "s/EXTLDFLAGS_STATIC='/&-fno-PIC /" hack/make.sh || die
-               grep -q -- '-fno-PIC' hack/make.sh || die 'hardened sed failed'
-
-               sed  "s/LDFLAGS_STATIC_DOCKER='/&-extldflags -fno-PIC /" \
-                       -i hack/make/dynbinary || die
-               grep -q -- '-fno-PIC' hack/make/dynbinary || die 'hardened sed failed'
-       fi
-
-       # let's set up some optional features :)
-       export DOCKER_BUILDTAGS=''
-       for gd in aufs btrfs device-mapper overlay; do
-               if ! use $gd; then
-                       DOCKER_BUILDTAGS+=" exclude_graphdriver_${gd//-/}"
-               fi
-       done
-
-       for tag in apparmor seccomp; do
-               if use $tag; then
-                       DOCKER_BUILDTAGS+=" $tag"
-               fi
-       done
-
-       # https://github.com/docker/docker/pull/13338
-       if use experimental; then
-               export DOCKER_EXPERIMENTAL=1
-       else
-               unset DOCKER_EXPERIMENTAL
-       fi
-
-       # time to build!
-       ./hack/make.sh dynbinary || die 'dynbinary failed'
-
-       # build the man pages too
-       ./man/md2man-all.sh || die "unable to generate man pages"
-}
-
-src_install() {
-       cd "src/${EGO_PN}" || die
-       VERSION="$(cat VERSION)"
-       newbin "bundles/$VERSION/dynbinary/docker-$VERSION" docker
-       #exeinto /usr/libexec/docker
-       #newexe "bundles/$VERSION/dynbinary/dockerinit-$VERSION" dockerinit
-
-       newinitd contrib/init/openrc/docker.initd docker
-       newconfd contrib/init/openrc/docker.confd docker
-
-       systemd_dounit contrib/init/systemd/docker.{service,socket}
-
-       udev_dorules contrib/udev/*.rules
-
-       dodoc AUTHORS CONTRIBUTING.md CHANGELOG.md NOTICE README.md
-       dodoc -r docs/*
-       doman man/man*/*
-
-       dobashcomp contrib/completion/bash/*
-
-       insinto /usr/share/zsh/site-functions
-       doins contrib/completion/zsh/*
-
-       insinto /usr/share/vim/vimfiles
-       doins -r contrib/syntax/vim/ftdetect
-       doins -r contrib/syntax/vim/syntax
-
-       # note: intentionally not using "doins" so that we preserve +x bits
-       mkdir -p "${D}/usr/share/${PN}/contrib"
-       cp -R contrib/* "${D}/usr/share/${PN}/contrib"
-}
-
-pkg_postinst() {
-       udev_reload
-
-       elog
-       elog "To use Docker, the Docker daemon must be running as root. To automatically"
-       elog "start the Docker daemon at boot, add Docker to the default runlevel:"
-       elog "  rc-update add docker default"
-       elog "Similarly for systemd:"
-       elog "  systemctl enable docker.service"
-       elog
-       elog "To use Docker as a non-root user, add yourself to the 'docker' group:"
-       elog "  usermod -aG docker youruser"
-       elog
-}
diff --git a/app-emulation/docker/docker-1.13.0_rc7.ebuild b/app-emulation/docker/docker-1.13.0_rc7.ebuild
deleted file mode 100644 (file)
index a631cb0..0000000
+++ /dev/null
@@ -1,287 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-EGO_PN="github.com/docker/docker"
-
-if [[ ${PV} = *9999* ]]; then
-       # Docker cannot be fetched via "go get", thanks to autogenerated code
-       EGIT_REPO_URI="https://${EGO_PN}.git"
-       EGIT_CHECKOUT_DIR="${WORKDIR}/${P}/src/${EGO_PN}"
-       inherit git-r3
-else
-       MY_PV="${PV/_/-}"
-       DOCKER_GITCOMMIT="48a9e53"
-       EGIT_COMMIT="v${MY_PV}"
-       SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64"
-       [ "$DOCKER_GITCOMMIT" ] || die "DOCKER_GITCOMMIT must be added manually for each bump!"
-       inherit golang-vcs-snapshot
-fi
-inherit bash-completion-r1 golang-base linux-info systemd udev user
-
-DESCRIPTION="The core functions you need to create Docker images and run Docker containers"
-HOMEPAGE="https://dockerproject.org"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="apparmor aufs btrfs +container-init +device-mapper hardened overlay pkcs11 seccomp"
-
-# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#build-dependencies
-CDEPEND="
-       >=dev-db/sqlite-3.7.9:3
-       device-mapper? (
-               >=sys-fs/lvm2-2.02.89[thin]
-       )
-       seccomp? ( >=sys-libs/libseccomp-2.2.1 )
-       apparmor? ( sys-libs/libapparmor )
-"
-
-DEPEND="
-       ${CDEPEND}
-
-       dev-go/go-md2man
-
-       btrfs? (
-               >=sys-fs/btrfs-progs-3.16.1
-       )
-"
-
-# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#runtime-dependencies
-# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#optional-dependencies
-RDEPEND="
-       ${CDEPEND}
-
-       !app-emulation/docker-bin
-       >=net-firewall/iptables-1.4
-       sys-process/procps
-       >=dev-vcs/git-1.7
-       >=app-arch/xz-utils-4.9
-
-       >=app-emulation/containerd-0.2.5
-       app-emulation/runc[apparmor?,seccomp?]
-       app-emulation/docker-proxy
-       container-init? ( >=sys-process/tini-0.13.0[static] )
-"
-
-RESTRICT="installsources strip"
-
-S="${WORKDIR}/${P}/src/${EGO_PN}"
-
-# see "contrib/check-config.sh" from upstream's sources
-CONFIG_CHECK="
-       ~NAMESPACES ~NET_NS ~PID_NS ~IPC_NS ~UTS_NS
-       ~CGROUPS ~CGROUP_CPUACCT ~CGROUP_DEVICE ~CGROUP_FREEZER ~CGROUP_SCHED ~CPUSETS ~MEMCG
-       ~KEYS
-       ~VETH ~BRIDGE ~BRIDGE_NETFILTER
-       ~NF_NAT_IPV4 ~IP_NF_FILTER ~IP_NF_TARGET_MASQUERADE
-       ~NETFILTER_XT_MATCH_ADDRTYPE ~NETFILTER_XT_MATCH_CONNTRACK
-       ~NF_NAT ~NF_NAT_NEEDED
-       ~POSIX_MQUEUE
-
-       ~USER_NS
-       ~SECCOMP
-       ~CGROUP_PIDS
-       ~MEMCG_SWAP ~MEMCG_SWAP_ENABLED
-
-       ~BLK_CGROUP ~BLK_DEV_THROTTLING ~IOSCHED_CFQ ~CFQ_GROUP_IOSCHED
-       ~CGROUP_PERF
-       ~CGROUP_HUGETLB
-       ~NET_CLS_CGROUP
-       ~CFS_BANDWIDTH ~FAIR_GROUP_SCHED ~RT_GROUP_SCHED
-       ~IP_VS ~IP_VS_PROTO_TCP ~IP_VS_PROTO_UDP ~IP_VS_NFCT
-
-       ~VXLAN
-       ~XFRM_ALGO ~XFRM_USER
-       ~IPVLAN
-       ~MACVLAN ~DUMMY
-"
-
-ERROR_KEYS="CONFIG_KEYS: is mandatory"
-ERROR_MEMCG_SWAP="CONFIG_MEMCG_SWAP: is required if you wish to limit swap usage of containers"
-ERROR_RESOURCE_COUNTERS="CONFIG_RESOURCE_COUNTERS: is optional for container statistics gathering"
-
-ERROR_BLK_CGROUP="CONFIG_BLK_CGROUP: is optional for container statistics gathering"
-ERROR_IOSCHED_CFQ="CONFIG_IOSCHED_CFQ: is optional for container statistics gathering"
-ERROR_CGROUP_PERF="CONFIG_CGROUP_PERF: is optional for container statistics gathering"
-ERROR_CFS_BANDWIDTH="CONFIG_CFS_BANDWIDTH: is optional for container statistics gathering"
-ERROR_XFRM_ALGO="CONFIG_XFRM_ALGO: is optional for secure networks"
-ERROR_XFRM_USER="CONFIG_XFRM_USER: is optional for secure networks"
-
-pkg_setup() {
-       if kernel_is lt 3 10; then
-               ewarn ""
-               ewarn "Using Docker with kernels older than 3.10 is unstable and unsupported."
-               ewarn " - http://docs.docker.com/engine/installation/binaries/#check-kernel-dependencies"
-       fi
-
-       # for where these kernel versions come from, see:
-       # https://www.google.com/search?q=945b2b2d259d1a4364a2799e80e8ff32f8c6ee6f+site%3Akernel.org%2Fpub%2Flinux%2Fkernel+file%3AChangeLog*
-       if ! {
-               kernel_is ge 3 16 \
-               || { kernel_is 3 15 && kernel_is ge 3 15 5; } \
-               || { kernel_is 3 14 && kernel_is ge 3 14 12; } \
-               || { kernel_is 3 12 && kernel_is ge 3 12 25; }
-       }; then
-               ewarn ""
-               ewarn "There is a serious Docker-related kernel panic that has been fixed in 3.16+"
-               ewarn "  (and was backported to 3.15.5+, 3.14.12+, and 3.12.25+)"
-               ewarn ""
-               ewarn "See also https://github.com/docker/docker/issues/2960"
-       fi
-
-       if kernel_is le 3 18; then
-               CONFIG_CHECK+="
-                       ~RESOURCE_COUNTERS
-               "
-       fi
-
-       if kernel_is le 3 13; then
-               CONFIG_CHECK+="
-                       ~NETPRIO_CGROUP
-               "
-       else
-               CONFIG_CHECK+="
-                       ~CGROUP_NET_PRIO
-               "
-       fi
-
-       if kernel_is lt 4 5; then
-               CONFIG_CHECK+="
-                       ~MEMCG_KMEM
-               "
-               ERROR_MEMCG_KMEM="CONFIG_MEMCG_KMEM: is optional"
-       fi
-
-       if kernel_is lt 4 7; then
-               CONFIG_CHECK+="
-                       ~DEVPTS_MULTIPLE_INSTANCES
-               "
-       fi
-
-       if use aufs; then
-               CONFIG_CHECK+="
-                       ~AUFS_FS
-                       ~EXT4_FS_POSIX_ACL ~EXT4_FS_SECURITY
-               "
-               ERROR_AUFS_FS="CONFIG_AUFS_FS: is required to be set if and only if aufs-sources are used instead of aufs4/aufs3"
-       fi
-
-       if use btrfs; then
-               CONFIG_CHECK+="
-                       ~BTRFS_FS
-                       ~BTRFS_FS_POSIX_ACL
-               "
-       fi
-
-       if use device-mapper; then
-               CONFIG_CHECK+="
-                       ~BLK_DEV_DM ~DM_THIN_PROVISIONING ~EXT4_FS ~EXT4_FS_POSIX_ACL ~EXT4_FS_SECURITY
-               "
-       fi
-
-       if use overlay; then
-               CONFIG_CHECK+="
-                       ~OVERLAY_FS ~EXT4_FS_SECURITY ~EXT4_FS_POSIX_ACL
-               "
-       fi
-
-       linux-info_pkg_setup
-
-       # create docker group for the code checking for it in /etc/group
-       enewgroup docker
-}
-
-src_compile() {
-       export GOPATH="${WORKDIR}/${P}:${PWD}/vendor"
-
-       # setup CFLAGS and LDFLAGS for separate build target
-       # see https://github.com/tianon/docker-overlay/pull/10
-       export CGO_CFLAGS="-I${ROOT}/usr/include"
-       export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
-
-       # if we're building from a tarball, we need the GITCOMMIT value
-       [ "$DOCKER_GITCOMMIT" ] && export DOCKER_GITCOMMIT
-
-       if use hardened; then
-               sed -i "s/EXTLDFLAGS_STATIC='/&-fno-PIC /" hack/make.sh || die
-               grep -q -- '-fno-PIC' hack/make.sh || die 'hardened sed failed'
-
-               sed  "s/LDFLAGS_STATIC_DOCKER='/&-extldflags -fno-PIC /" \
-                       -i hack/make/dynbinary-client || die
-               sed  "s/LDFLAGS_STATIC_DOCKER='/&-extldflags -fno-PIC /" \
-                       -i hack/make/dynbinary-daemon || die
-               grep -q -- '-fno-PIC' hack/make/dynbinary-daemon || die 'hardened sed failed'
-               grep -q -- '-fno-PIC' hack/make/dynbinary-client || die 'hardened sed failed'
-       fi
-
-       # let's set up some optional features :)
-       export DOCKER_BUILDTAGS=''
-       for gd in aufs btrfs device-mapper overlay; do
-               if ! use $gd; then
-                       DOCKER_BUILDTAGS+=" exclude_graphdriver_${gd//-/}"
-               fi
-       done
-
-       for tag in apparmor pkcs11 seccomp; do
-               if use $tag; then
-                       DOCKER_BUILDTAGS+=" $tag"
-               fi
-       done
-
-       # time to build!
-       ./hack/make.sh dynbinary || die 'dynbinary failed'
-
-       # build the man pages too
-       ./man/md2man-all.sh || die "unable to generate man pages"
-}
-
-src_install() {
-       VERSION="$(cat VERSION)"
-       newbin "bundles/$VERSION/dynbinary-client/docker-$VERSION" docker
-       newbin "bundles/$VERSION/dynbinary-daemon/dockerd-$VERSION" dockerd
-       dosym containerd /usr/bin/docker-containerd
-       dosym containerd-shim /usr/bin/docker-containerd-shim
-       dosym runc /usr/bin/docker-runc
-       use container-init && dosym tini /usr/bin/docker-init
-
-       newinitd contrib/init/openrc/docker.initd docker
-       newconfd contrib/init/openrc/docker.confd docker
-
-       systemd_dounit contrib/init/systemd/docker.{service,socket}
-
-       udev_dorules contrib/udev/*.rules
-
-       dodoc AUTHORS CONTRIBUTING.md CHANGELOG.md NOTICE README.md
-       dodoc -r docs/*
-       doman man/man*/*
-
-       dobashcomp contrib/completion/bash/*
-
-       insinto /usr/share/zsh/site-functions
-       doins contrib/completion/zsh/_*
-
-       insinto /usr/share/vim/vimfiles
-       doins -r contrib/syntax/vim/ftdetect
-       doins -r contrib/syntax/vim/syntax
-
-       # note: intentionally not using "doins" so that we preserve +x bits
-       dodir /usr/share/${PN}/contrib
-       cp -R contrib/* "${ED}/usr/share/${PN}/contrib"
-}
-
-pkg_postinst() {
-       udev_reload
-
-       elog
-       elog "To use Docker, the Docker daemon must be running as root. To automatically"
-       elog "start the Docker daemon at boot, add Docker to the default runlevel:"
-       elog "  rc-update add docker default"
-       elog "Similarly for systemd:"
-       elog "  systemctl enable docker.service"
-       elog
-       elog "To use Docker as a non-root user, add yourself to the 'docker' group:"
-       elog "  usermod -aG docker youruser"
-       elog
-}
diff --git a/app-emulation/docker/files/docker-containerd.patch b/app-emulation/docker/files/docker-containerd.patch
deleted file mode 100644 (file)
index c53e82e..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/libcontainerd/remote_linux.go b/libcontainerd/remote_linux.go
-index f0284ca..e44a1d1 100644
---- a/libcontainerd/remote_linux.go
-+++ b/libcontainerd/remote_linux.go
-@@ -27,7 +27,7 @@ const (
-       maxConnectionRetryCount   = 3
-       connectionRetryDelay      = 3 * time.Second
-       containerdShutdownTimeout = 15 * time.Second
--      containerdBinary          = "docker-containerd"
-+      containerdBinary          = "containerd"
-       containerdPidFilename     = "docker-containerd.pid"
-       containerdSockFilename    = "docker-containerd.sock"
-       eventTimestampFilename    = "event.ts"
-@@ -338,7 +338,7 @@ func (r *remote) runContainerdDaemon() error {
-       }
-       // Start a new instance
--      args := []string{"-l", r.rpcAddr, "--runtime", "docker-runc"}
-+      args := []string{"-l", r.rpcAddr, "--runtime", "runc"}
-       if r.debugLog {
-               args = append(args, "--debug", "true")
-       }