net-news/rawdog: EAPI 6 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Mon, 29 May 2017 13:34:22 +0000 (15:34 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 29 May 2017 13:36:57 +0000 (15:36 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.1

net-news/rawdog/rawdog-2.22-r1.ebuild [new file with mode: 0644]

diff --git a/net-news/rawdog/rawdog-2.22-r1.ebuild b/net-news/rawdog/rawdog-2.22-r1.ebuild
new file mode 100644 (file)
index 0000000..e6ef615
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Rawdog, RSS Aggregator Without Delusions Of Grandeur"
+HOMEPAGE="http://offog.org/code/rawdog.html https://pypi.python.org/pypi/rawdog"
+SRC_URI="http://offog.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~s390 ~sparc ~x86"
+
+DEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_test() {
+       # pypy fails half way through; meh
+       ./test-rawdog || die "Test run aborted"
+}